[ 
https://issues.apache.org/jira/browse/HBASE-12645?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14248687#comment-14248687
 ] 

Varun Saxena commented on HBASE-12645:
--------------------------------------

bq. "Whether to get a new root or data dir path even if such a path has been 
fetched earlier is decided based on flag getNewRootDirPathIfExists"
bq. What is 'get a new root or data dir path' and what does 'fetched' mean 
here? Does it mean created (create with override)? (I think it means this 
latter – one of your javadoc param notes says so... I'd think all mention of 
this flag in javadoc would have same text?)
Well, the creation of root directory and fetching of path of root directory are 
2 distinct operations. {{createRootDir()}} fetches the path of root directory 
by calling {{getDefaultRootDirPath()}} and then creates it(overwrites if path 
exists). 
Whenever we fetch or get a root or data directory path we mark it(variable 
{{dataTestDirOnTestFS}} will be null if path hasnt been retrieved earlier). 
The flag {{getNewRootDirPathIfExists}} indicates whether this flow of getting 
path has been hit before or not by checking whether {{dataTestDirOnTestFS}} is 
null or not.
Flag name has been kept like this for the lack of a proper name. Didnt sound 
great even to me. Probably you can suggest a better name.


> HBaseTestingUtility is using ${$HOME} for rootDir
> -------------------------------------------------
>
>                 Key: HBASE-12645
>                 URL: https://issues.apache.org/jira/browse/HBASE-12645
>             Project: HBase
>          Issue Type: Test
>          Components: test
>    Affects Versions: 1.0.0
>            Reporter: Nick Dimiduk
>            Assignee: Varun Saxena
>            Priority: Critical
>             Fix For: 1.0.0, 2.0.0
>
>         Attachments: HBASE-12645.002.patch, HBASE-12645.003.patch, 
> HBASE-12645.004.patch, HBASE-12645.004.patch, HBASE-12645.005.patch, 
> HBASE-12645.006.patch, HBASE-12645.006.patch, HBASE-12645.patch
>
>
> I noticed this while running tests on branch-1
> {noformat}
> Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 0.009 sec <<< 
> FAILURE! - in 
> org.apache.hadoop.hbase.regionserver.wal.TestReadOldRootAndMetaEdits
> org.apache.hadoop.hbase.regionserver.wal.TestReadOldRootAndMetaEdits  Time 
> elapsed: 0.009 sec  <<< ERROR!
> java.io.FileNotFoundException: Destination exists and is not a directory: 
> /homes/hortonnd/hbase
>         at 
> org.apache.hadoop.fs.RawLocalFileSystem.mkdirs(RawLocalFileSystem.java:423)
>         at 
> org.apache.hadoop.fs.ChecksumFileSystem.mkdirs(ChecksumFileSystem.java:588)
>         at 
> org.apache.hadoop.hbase.HBaseTestingUtility.createRootDir(HBaseTestingUtility.java:1053)
>         at 
> org.apache.hadoop.hbase.regionserver.wal.TestReadOldRootAndMetaEdits.setupBeforeClass(TestReadOldRootAndMetaEdits.java:70)
> {noformat}
> Either the testing utility has a regression or there's a config regression in 
> this test.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to