[ 
https://issues.apache.org/jira/browse/HBASE-19678?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16329297#comment-16329297
 ] 

stack commented on HBASE-19678:
-------------------------------

[~yuzhih...@gmail.com] I have to do my own investigation as to what is going on 
in this issue. Why no clarifying note on the end here that explains the state? 
(Author is wrong in the commits as is the adding BELUGA BEHR as suffix in 
parenthesis).

 

The committed patch looks like it got applied and then reverted:

 

commit c2ca90f0fb5177372e9f72917d67b49014a54b5b
Author: tedyu <yuzhih...@gmail.com>
Date: Sun Dec 31 11:32:14 2017 -0800

HBASE-19678 HBase Admin security capabilities should be represented as a Set 
(BELUGA BEHR)

 

commit c394f3919e7981247c60a3d3b075ee554cee826b
Author: tedyu <yuzhih...@gmail.com>
Date: Mon Jan 1 14:16:46 2018 -0800

HBASE-19678 HBase Admin security capabilities should be represented as a Set - 
revert due to wrong issue

> HBase Admin security capabilities should be represented as a Set
> ----------------------------------------------------------------
>
>                 Key: HBASE-19678
>                 URL: https://issues.apache.org/jira/browse/HBASE-19678
>             Project: HBase
>          Issue Type: Improvement
>          Components: hbase
>    Affects Versions: 3.0.0
>            Reporter: BELUGA BEHR
>            Assignee: BELUGA BEHR
>            Priority: Minor
>             Fix For: 2.0.0
>
>
> {code:title=org.apache.hadoop.hbase.client.Admin}
>   /**
>    * Return the set of supported security capabilities.
>    * @throws IOException
>    * @throws UnsupportedOperationException
>    */
>   List<SecurityCapability> getSecurityCapabilities() throws IOException;
> {code}
> The comment says a "set" but it returns a List.  A Set would be the most 
> appropriate data structure here, an immutable one perhaps, because the code 
> that interacts with it looks up information using the _contains_ method which 
> would be served well by a Set.  Please change this interface to return a Set.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to