[ 
https://issues.apache.org/jira/browse/HBASE-20853?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16540161#comment-16540161
 ] 

Chia-Ping Tsai commented on HBASE-20853:
----------------------------------------

 
{quote}How increment relates to delete?
{quote}
Do you point to this comment?
{quote}
{code:java}
+ CheckAndMutateBuilder builder = checkAndMutate(row, family);
+ return builder.qualifier(qualifier).ifEquals(value).thenDelete(delete);{code}
Perhaps the local variable can be eliminated... Make it more "fluent":)
{quote}
If so, what I want to do is to change the above code to "
{code:java}
return  checkAndMutate(row, 
family).qualifier(qualifier).ifEquals(value).thenDelete(delete);{code}

> Polish "Add defaults to Table Interface so Implementors don't have to"
> ----------------------------------------------------------------------
>
>                 Key: HBASE-20853
>                 URL: https://issues.apache.org/jira/browse/HBASE-20853
>             Project: HBase
>          Issue Type: Sub-task
>          Components: API
>            Reporter: stack
>            Assignee: Balazs Meszaros
>            Priority: Major
>              Labels: beginner, beginners
>             Fix For: 3.0.0, 2.0.2, 2.1.1
>
>         Attachments: HBASE-20853.master.001.patch
>
>
> This issue is to address feedback that came in after commit on the parent 
> (FYI [~chia7712]). See tail of parent issue and amendment attached to parent 
> adding better defaults to the Table Interface.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to