[ 
https://issues.apache.org/jira/browse/HBASE-6241?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13402458#comment-13402458
 ] 

Zhihong Ted Yu commented on HBASE-6241:
---------------------------------------

{code}
+          cluster.abortRegionServer(selected);
+          sleep(ONE_MIN);
+          cluster.startRegionServer(servers[selected].getHostname());
+          sleep(ONE_MIN);
{code}
Is there better way to detect the stop of region server has completed ?
{code}
+  public static enum ServiceType {
{code}
Should job/task tracker be in the enum as well ?
{code}
+  public abstract boolean signal(ServiceType service, String signal, String 
hostname) throws IOException;
{code}
Line length should be 100 chars or shorter.

For HBaseCluster.java, remove year in license.
{code}
+   * @return Name of master that just went down.
+   */
+  public abstract String waitOnMaster(final int serverNumber);
{code}
If no enum argument is planned to be added, the method can be renamed as 
waitOnMasterToStop().
{code}
+  public void restoreInitialState() throws IOException {
{code}
How about restoring to one of the ClusterStatus previously captured by 
getClusterStatus() ? (future enhancement)

I think getInitialClusterStatus() and getClusterStatus() can be unified into 
one method with enum indicating the type of status.
{code}
+   * @return Index into List of {@link 
MiniHBaseCluster#getRegionServerThreads()}
+   * of HRS carrying .META.. Returns -1 if none found.
+   */
+  public abstract int getServerWith(byte[] regionName) throws IOException;
{code}
The return value isn't just for .META. server. Its javadoc, should be improved 
- considering MiniHBaseCluster being a subclass of HBaseCluster.

More review comments to follow.
                
> HBaseCluster interface for interacting with the cluster from system tests 
> --------------------------------------------------------------------------
>
>                 Key: HBASE-6241
>                 URL: https://issues.apache.org/jira/browse/HBASE-6241
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Enis Soztutar
>            Assignee: Enis Soztutar
>         Attachments: HBASE-6241_v0.2.patch
>
>
> We need to abstract away the cluster interactions for system tests running on 
> actual clusters. 
> MiniHBaseCluster and RealHBaseCluster should both implement this interface, 
> and system tests should work with both.
> I'll split Devaraj's patch in HBASE-6053 for the initial version. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to