[ 
https://issues.apache.org/jira/browse/HBASE-6241?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13404330#comment-13404330
 ] 

Enis Soztutar commented on HBASE-6241:
--------------------------------------

Forgot to mention that patch at RB addresses all of the Ted's comments above, 
except: 
bq. If no enum argument is planned to be added, the method can be renamed as 
waitOnMasterToStop().

renamed methods like waitForMasterToStop()

bq. +  public void restoreInitialState() throws IOException {
bq. How about restoring to one of the ClusterStatus previously captured by 
getClusterStatus() ? (future enhancement)
bq. I think getInitialClusterStatus() and getClusterStatus() can be unified 
into one method with enum indicating the type of status.

Now, we have restoreInitialStatus(), and restoreClusterStatus(ClusterStatus 
desiredStatus). The former just calls the latter with the result from 
getInitialClusterStatus()

bq. For HBaseTestingUtility.java:
{code}
+    } catch (Exception ex) {
+      throw new RuntimeException(ex);
+    }
{code}
Moved the exception catching an throwing into the constructor. 
                
> HBaseCluster interface for interacting with the cluster from system tests 
> --------------------------------------------------------------------------
>
>                 Key: HBASE-6241
>                 URL: https://issues.apache.org/jira/browse/HBASE-6241
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Enis Soztutar
>            Assignee: Enis Soztutar
>         Attachments: HBASE-6241_v0.2.patch, HBASE-6241_v1.patch
>
>
> We need to abstract away the cluster interactions for system tests running on 
> actual clusters. 
> MiniHBaseCluster and RealHBaseCluster should both implement this interface, 
> and system tests should work with both.
> I'll split Devaraj's patch in HBASE-6053 for the initial version. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to