[ 
https://issues.apache.org/jira/browse/HBASE-5145?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13409286#comment-13409286
 ] 

Zhihong Ted Yu commented on HBASE-5145:
---------------------------------------

Here is javadoc for waitForRegionServers():
{code}
   * Wait for the region servers to report in.
   * We will wait until one of this condition is met:
   *  - the master is stopped
   *  - the 'hbase.master.wait.on.regionservers.timeout' is reached
   *  - the 'hbase.master.wait.on.regionservers.maxtostart' number of
   *    region servers is reached
   *  - the 'hbase.master.wait.on.regionservers.mintostart' is reached AND
   *   there have been no new region server in for
   *      'hbase.master.wait.on.regionservers.interval' time
{code}
If we expose 'hbase.master.wait.on.regionservers.mintostart', we should expose 
the other parameters as well ?

Also, the following is difficult to follow:
{code}
    opt.addOption("minServers", true, "Minimum RegionServers needed to host 
user tables");
{code}
We should change the wording.

What do you think ?
                
> HMasterCommandLine's -minServers seems to be useless.
> -----------------------------------------------------
>
>                 Key: HBASE-5145
>                 URL: https://issues.apache.org/jira/browse/HBASE-5145
>             Project: HBase
>          Issue Type: Sub-task
>          Components: master
>    Affects Versions: 0.94.0
>            Reporter: Harsh J
>            Assignee: Harsh J
>         Attachments: HBASE-5145.patch
>
>
> HMasterCommandLine gets a number via -minServers opt. and sets it to a config 
> param "hbase.regions.server.count.min".
> This config is not used anywhere else.
> Perhaps it wants to use "hbase.master.wait.on.regionservers.mintostart" 
> instead?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to