[ https://issues.apache.org/jira/browse/HBASE-6580?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13508176#comment-13508176 ]
Lars Hofhansl commented on HBASE-6580: -------------------------------------- Also as part of this, I would like to propose to remove HTablePool for good. (You do not have to do this part Andrian, unless you like to :), I'll happily do an addon patch. > New HTable pool, based on HBase(byte[], HConnection, ExecutorService) > constructor > --------------------------------------------------------------------------------- > > Key: HBASE-6580 > URL: https://issues.apache.org/jira/browse/HBASE-6580 > Project: HBase > Issue Type: Improvement > Affects Versions: 0.92.2, 0.94.2 > Reporter: Lars Hofhansl > Priority: Minor > Attachments: HBASE-6580_v1.patch, HBASE-6580_v2.patch > > > Here I propose a very simple TablePool. > It could be called LightHTablePool (or something - if you have a better name). > Internally it would maintain an HConnection and an Executor service and each > invocation of getTable(...) would create a new HTable and close() would just > close it. > In testing I find this more light weight than HTablePool and easier to > monitor in terms of resources used. > It would hardly be more than a few dozen lines of code. -- This message is automatically generated by JIRA. If you think it was sent incorrectly, please contact your JIRA administrators For more information on JIRA, see: http://www.atlassian.com/software/jira