[ 
https://issues.apache.org/jira/browse/HIVE-19307?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16461615#comment-16461615
 ] 

Jason Dere commented on HIVE-19307:
-----------------------------------

A few things:

Nit: LlapOutputFormatService.java has a tab in the indentation, plus the 
indentation seems to be tab-aligned (too many spaces).
Nit: SemanticAnalyzer.java has a couple of lines with trailing whitespace
FileSinkOperator: This is checking FileSinkDesc.isUsingThriftJDBCBinarySerDe(). 
I wonder if the field/method in FileSinkDesc should be renamed to 
isUsingBatchingSerializer.

WritableByteChannelAdapter:
- Maybe some comments related to takeWriteResources() and the reason for that.
- I know this is based on ChannelOutputStream, but actually I see now that the 
writeListener could be implemented in such a way as to propagate a write error 
back to the writer (so we can possibly throw an exception and fail the current 
operation rather than just log and ignore the error). Plus on close I'm 
wondering if it is better just to wait for the close future to complete so we 
can check the status. If you want we can take an item to address this later.


> Support ArrowOutputStream in LlapOutputFormatService
> ----------------------------------------------------
>
>                 Key: HIVE-19307
>                 URL: https://issues.apache.org/jira/browse/HIVE-19307
>             Project: Hive
>          Issue Type: Task
>          Components: llap
>            Reporter: Eric Wohlstadter
>            Assignee: Eric Wohlstadter
>            Priority: Major
>         Attachments: HIVE-19307.3.patch
>
>
> Support pushing arrow batches through 
> org.apache.arrow.vector.ipc.ArrowOutputStream in LllapOutputFormatService.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to