[ 
https://jira.codehaus.org/browse/SUREFIRE-1054?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=356741#comment-356741
 ] 

Tibor Digana commented on SUREFIRE-1054:
----------------------------------------

@Melloware
My proposal for your management would be to let them know that the idioms are:
+ naming conventions for unit test classes *Test.java, e.g. SomeUnitTest.java
+ naming conventions for IT integration tests *IT.java, e.g. ApplicationIT.java
In this case there's not need to use @Category.

> "test" property overrides "excludes" but not "excludedGroups"
> -------------------------------------------------------------
>
>                 Key: SUREFIRE-1054
>                 URL: https://jira.codehaus.org/browse/SUREFIRE-1054
>             Project: Maven Surefire
>          Issue Type: Bug
>          Components: Maven Surefire Plugin
>    Affects Versions: 2.16
>         Environment: Maven 3.1.1, JUnit 4.11, maven-surefire-plugin 2.16
>            Reporter: Elizabeth Chatman
>            Assignee: Tibor Digana
>
> I recently changed my maven configuration to use the "excludedGroups" 
> property instead of "excludes", and found that I can no longer run individual 
> tests if they are part of the excludedGroups.
> Example:
> My default configuration used to look like this (using path and filename 
> matching to try to match groups of tests):
> {code:xml}
> <excludes>
>   <exclude>**/integration/**</exclude>
>   <exclude>**/*IntegrationTest.java</exclude>
> </excludes>
> {code}
> My new configuration, after annotating my integration tests with 
> {{@Category(IntegrationTests.class)}}:
> {code:xml}<excludedGroups>com.mycompany.IntegrationTests</excludedGroups>{code}
> Previously, I could run a single integration test using:
> {{mvn test -Dtest=NameOfIntegrationTest}}
> Now that command fails ("No tests were executed!") unless I manually override 
> the excludedGroups property ({{mvn test -Dtest=NameOfIntegrationTest 
> -DexcludedGroups=}})



--
This message was sent by Atlassian JIRA
(v6.1.6#6162)

Reply via email to