I can't find my post about naming convention, so here it goes again...

Do you agree to name samples as:

   <picname>_<testname>.jal

where testname is the test's filename without "test_".

Ex:

 - board: board_16f648a_js.jal
 - test: test_serial_hardware.jal
 - sample: 16f648a_serial_hardware.jal


(btw, I'm still afraid about collisions between "manual" samples and
generated ones...)



Seb


On 27 déc, 14:38, "Sebastien Lelong" <[email protected]>
wrote:
> Hi Rob,
> Yes I could use any prefixes, but since we used terms "board" and "test"
> which combined give "sample", I wanted to keep the same vocabulary. But I
> can set no prefix at all too, I agree. I wanted to be able
> to distinguish those generated from others, but I also agree users don't
> have this background, and don't have to.
>
> About pictype: do you mean users may copy/paste all samples from each pic
> directory to a single directory ? If so, then OK, we should also add the PIC
> name.
>
> So:
>
>  * OK for removing "sample_" prefix, provided there's no collision
>  * OK for adding PIC type
>
> Let's also wait for more feedback from others to see their point of this.
>
> Cheers,
> Seb
>
> 2008/12/26 Rob Hamerling <[email protected]>
>
>
>
>
>
> > Sebastien Lelong wrote:
>
> > > about samples starting with "sample_": i'd like to introduce a new
> > > naming convention. when samples are generated from a board and a test
> > > file, i need a way to name the generated file. logically, i decided
> > > to use sample_ . this means when it's starting with this prefix, you
> > > know it's been generated (and those which did not). some of eur's
> > > samples (and one of yours now i think) are named like this, and
> > > shouldn't since they aren't generated.
>
> > You could have used anything as prefix, even no prefix at all, because
> > the generated sample will be unique in the <pictype> directory.
>
> > But the point is: the user of a download package doesn't have this
> > background information. He may ask (at least I would) "what is the
> > difference between samples of which the filename starts with sample_ and
> > other samples?". I would like to avoid spending time to explain this to
> > every user (and save time for 'real' support).
>
> > > about pic name: i don't have strong opinion on this. i may prefer
> > > without it, since samples are released in different dir (one per pic)
> > > so no need to repeat the information. this can also make the filename
> > > a little bit lighter.
>
> > Yes, but I also said that users might prefer to have all samples in a
> > single directory and then the filename must be made unique and indicate
> > the pictype.   (For the samples generated from a board file you could
> > also add the PICtype to the name).
>
> > If we decide to keep separate subdirectories for each pictype I could
> > rename all my blink samples to 'blink.jal'.
>
> > Regards, Rob
>
> > --
> > Rob Hamerling, Vianen, NL (http://www.robh.nl/)
>
> --
> Sébastien Lelonghttp://www.sirloon.nethttp://sirbot.org
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"jallib" group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to 
[email protected]
For more options, visit this group at 
http://groups.google.com/group/jallib?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to