2008/12/29 Joep Suijs <[email protected]> > > 2008/12/29, Sebastien Lelong <[email protected]>: > > > > I can't find my post about naming convention, so here it goes again... > > > > Do you agree to name samples as: > > > > <picname>_<testname>.jal > > > > where testname is the test's filename without "test_". > > > > Ex: > > > > - board: board_16f648a_js.jal > > - test: test_serial_hardware.jal > > - sample: 16f648a_serial_hardware.jal > Yes! > > btw: You don't rely on the pic name in the board file name, but the > include statement in the board, don't you?
No ! I rely on a naming convention... :) See JSG: """ Samples and tests Tests are named as test_<whatever>.jal. That is, they should starts with the prefix test_. That is, samples must not start with test_. Board files are named as board_<pic>_<whatever>.jal """ This makes my life easier... > > (btw, I'm still afraid about collisions between "manual" samples and > > generated ones...) > That remains a risk, but we can get around that by choosing the test > file name carefully. And when is goes wrong, we always have our svn :) > > OK, then I will: * rename Eur's samples starting with "sample_" myself * modify my script (jallib.py) to replace "sample_" by PIC name * delete previously generated samples starting with "sample_" * generate new ones (and only commit those corresponding to the deleted) * update TORELEASE Please don't generate and commit any samples during this... Cheers, Seb -- Sébastien Lelong http://www.sirloon.net http://sirbot.org --~--~---------~--~----~------------~-------~--~----~ You received this message because you are subscribed to the Google Groups "jallib" group. To post to this group, send email to [email protected] To unsubscribe from this group, send email to [email protected] For more options, visit this group at http://groups.google.com/group/jallib?hl=en -~----------~----~----~----~------~----~------~--~---
