Updates:
Status: Started
Comment #2 on issue 92 by robhamerling: 'high' and 'low' resolution in pwm
libraries
http://code.google.com/p/jallib/issues/detail?id=92
I agree that a procedure with an 8-bits value can be convenient.
The 'wrong' part is that it suggests that it is 'low resolution', but in
fact it is
'high resolution' (10 bits) with the 2 low order bits truncated. High or
low
resolution does not depend on which procedure you call but on the value you
pass to
it. That is misleading naming.
I have the intention to change pwmx_set_dutycycle(byte in duty) so that it
becomes
really low-resolution: 2 low order bits go to CCPxCON_DCxB and the high
order 6 bits
go to CCPRxL. In fact it can become a call to pwmx_set_dutycycle_highres()
with the
byte 'duty' casted to a word.
When a byte-value has to be used to set the duty cycle in high resolution
mode it can
be done with a call to pwmx_set_dutycycle_highres() by casting it to a word.
--
You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:
http://code.google.com/hosting/settings
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups
"jallib" group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to
[email protected]
For more options, visit this group at
http://groups.google.com/group/jallib?hl=en
-~----------~----~----~----~------~----~------~--~---