[ 
https://issues.apache.org/jira/browse/LUCENE-1990?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12843027#action_12843027
 ] 

Toke Eskildsen commented on LUCENE-1990:
----------------------------------------

Michael McCandless:
{quote}
    * I think we shouldn't add Aligned*.java to svn? It'll just add
      unused bits to the JAR, and, we can always fallback to this issue
      to pull them in at a future time?
{quote}

I agree. At the current state, Aligned is just dead weight.

This also means that the performance tester won't be part of the commit though. 
I can quickly make a performance tester that does not use aligned, if it is 
preferable to keep performance testing.

{quote}
    * Can you resolve the remaining nocommits? EG (since we are
      unsigned) we can't get the 64 bit case working. I don't think we
      should rename to UnsignedXXX, nor, support minValue at this
      point, and remove the ComparableBytesRef, and I'll merge BytesRef
      into flex's when I commit.

I can take these too - I think it's ready to commit on flex after this
{quote}

It will help a lot if you take care of these issues, thanks.

> Add unsigned packed int impls in oal.util
> -----------------------------------------
>
>                 Key: LUCENE-1990
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1990
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Index
>    Affects Versions: Flex Branch
>            Reporter: Michael McCandless
>            Priority: Minor
>             Fix For: Flex Branch
>
>         Attachments: generated_performance-te20100226.txt, 
> LUCENE-1990-te20100122.patch, LUCENE-1990-te20100210.patch, 
> LUCENE-1990-te20100212.patch, LUCENE-1990-te20100223.patch, 
> LUCENE-1990-te20100226.patch, LUCENE-1990-te20100226b.patch, 
> LUCENE-1990-te20100226c.patch, LUCENE-1990-te20100301.patch, 
> LUCENE-1990.patch, LUCENE-1990_PerformanceMeasurements20100104.zip, 
> perf-mkm-20100227.txt, performance-20100301.txt, performance-te20100226.txt
>
>
> There are various places in Lucene that could take advantage of an
> efficient packed unsigned int/long impl.  EG the terms dict index in
> the standard codec in LUCENE-1458 could subsantially reduce it's RAM
> usage.  FieldCache.StringIndex could as well.  And I think "load into
> RAM" codecs like the one in TestExternalCodecs could use this too.
> I'm picturing something very basic like:
> {code}
> interface PackedUnsignedLongs  {
>   long get(long index);
>   void set(long index, long value);
> }
> {code}
> Plus maybe an iterator for getting and maybe also for setting.  If it
> helps, most of the usages of this inside Lucene will be "write once"
> so eg the set could make that an assumption/requirement.
> And a factory somewhere:
> {code}
>   PackedUnsignedLongs create(int count, long maxValue);
> {code}
> I think we should simply autogen the code (we can start from the
> autogen code in LUCENE-1410), or, if there is an good existing impl
> that has a compatible license that'd be great.
> I don't have time near-term to do this... so if anyone has the itch,
> please jump!

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: java-dev-h...@lucene.apache.org

Reply via email to