The object model is fine, but this should be in the deployment
package as it is the object model corresponding to the j2ee
+ jboss packages. It should not depend on any specific container
other than a reference to the container ObjectName.

>
> > The DeploymentInfo object groups all of the elements together in
> > a heirarchy of components. This object is not passed into the
> > method that creates these ejb links. We need to unify the objects
> > created to model the deployment and get rid of legacy classes.
> > Through the complete DeploymentInfo it would be easy to handle
> > cross ejb-jar links. See the DeploymentInfo.findEjbLink code.
>
> The question is: do you want, that Container depends on DeploymentInfo?
> Rather not! IMHO we should keep all these *Deployment / DeploymentInfo
> classes out of the Application-(EJB|Web)Module-Container hierarchy.
>
> Thus:
>
> o rename Application to Module
> o implement the classes Module, EJBModule, WebModule (give them a method
>   getApplication())
> o implement a new class, called Application that models an enterprise
>   application and contains a bunch of Modules
> o implement a sophisticated getContainer() method, that conforms to
>   ejb-spec-2_0, chapter 20.3.2
>
> o implement an EARDeployer, that is activated by the MainDeployer instead
>   of the method deploySubPackages
>
> Holger



_______________________________________________
Jboss-development mailing list
[EMAIL PROTECTED]
https://lists.sourceforge.net/lists/listinfo/jboss-development

Reply via email to