On Oct 10, 8:58 am, "Andrea Giammarchi" <[EMAIL PROTECTED]>
wrote:
> I meant something like
>
> function A(){};
> __getClass(new A); // Object
>
> that's good or logical enough, but as getClass function I would expect "A"
> and not "Object"

I see what you mean and I see how JavaScript newcomers would
"understand" it this way. The thing is that once you know that there
are no "classes" (nor are there function "names") in JS, there
shouldn't be such confusion ; )

Maybe, a better name would be - `getInternalType` or
`getInternalClass` (to emphasize the internal nature of a property).

>
> This was just a little inconsistency about function name, nothing that
> important :-)
>
> Regards
>
> On Fri, Oct 10, 2008 at 1:31 PM, kangax <[EMAIL PROTECTED]> wrote:
> > Sorry, I lost you here. "Object with every instance that is not
> > native"? What do you mean?

--
kangax
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"jQuery Development" group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/jquery-dev?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to