Or the name could be changed for jQuery 1.4 and a plugin provided for
the compatibility with 1.3 code.

It has been the jQuery policy for some time now.

On Mar 24, 5:25 pm, Eric Garside <gars...@gmail.com> wrote:
> Yea, the backwards compatibility is really the major issue with making
> a basically cosmetic change.
>
> On Mar 24, 12:04 pm, benjamw <benjamwel...@gmail.com> wrote:
>
>
>
> > Yeah, I agree with Mike521, if I were to stumble onto that function
> > without any related documentation, I would assume it to return a
> > boolean value as well.  While I agree with the "kill two birds with
> > one stone" argument against changing the actual function, indexOf
> > seems to be a more intuitive function name while still remaining short
> > in length (shorter than arrayPosition).  Although it may be more of a
> > headache to change now, with the risk breaking innumerable plugins and
> > pages.
>
> > On Mar 23, 10:58 pm, Eric Garside <gars...@gmail.com> wrote:
>
> > > If you'd prefer shortcut functionality, try:
>
> > > $.isInArray = function(arr){ return $.inArray(arr) > -1 ? true :
> > > false }
>
> > > On Mar 23, 4:59 pm, Klaus Hartl <klaus.ha...@googlemail.com> wrote:
>
> > > > Read inArray as positionInArray rather than isInArray here...
>
> > > > --Klaus
>
> > > > On 23 Mrz., 21:25, MorningZ <morni...@gmail.com> wrote:
>
> > > > > Yeah, like what he is suggesting is to return a boolean value....   so
> > > > > now if someone wants the position of the item, it would be a whole
> > > > > separate function to do so....
>
> > > > > to me, one single function and checking the value is more "intuitive",
> > > > > maybe if it was named something more inline with what it returns (like
> > > > > for instance, "indexOf") makes more sense, but none the less the
> > > > > function kills two birds with one stone
>
> > > > > On Mar 23, 4:19 pm, Eric Garside <gars...@gmail.com> wrote:
>
> > > > > > Honestly, inArray and arrayPosition are equally intuitive to me. If
> > > > > > the value has a position in the array, then it is, by definition, in
> > > > > > the array. inArray returning the array position is a similar check,
> > > > > > but with a more robust ouput. Again, as MorningZ said, you can 
> > > > > > simply
> > > > > > check it's value using a simple gt operator. I honestly don't care 
> > > > > > too
> > > > > > much about inArray returning a non-boolean value which may be
> > > > > > unintuitive to some users. After all, the docs are there for a
> > > > > > reason.
>
> > > > > > On Mar 23, 3:51 pm, Mike521 <mi...@favorfavor.com> wrote:
>
> > > > > > > I'm not discussing whether I can or can't use it the way it is, 
> > > > > > > I'm
> > > > > > > discussing which way is more intuitive.
>
> > > > > > > On Mar 23, 3:18 pm, MorningZ <morni...@gmail.com> wrote:
>
> > > > > > > > just can't say
>
> > > > > > > > if ($.inArray("value", array) > -1) {
> > > > > > > >    // found in array?
>
> > > > > > > > }
>
> > > > > > > > On Mar 23, 2:59 pm, Mike521 <mi...@favorfavor.com> wrote:
>
> > > > > > > > > I was about to use inArray (http://docs.jquery.com/Utilities/
> > > > > > > > > jQuery.inArray) to determine if an element was in an array or 
> > > > > > > > > not, but
> > > > > > > > > I realized I can't use it as a true/false response since it 
> > > > > > > > > returns
> > > > > > > > > the position (and could return 0 if the element was found in 
> > > > > > > > > position
> > > > > > > > > 0 - returns -1 if not found). I was expecting something with 
> > > > > > > > > the same
> > > > > > > > > functionality as the PHP function in_array 
> > > > > > > > > (http://us3.php.net/
> > > > > > > > > in_array)
>
> > > > > > > > > I know it's a minor point but wouldn't it be more intuitive 
> > > > > > > > > if called
> > > > > > > > > arrayPosition? with a name like that I'd expect the 
> > > > > > > > > functionality it
> > > > > > > > > has now.

Reply via email to