Hi all
I have changed the setup to focus only on the xconnect between Cisco and
Juniper
The topology is simple :
CE1 - Cisco PE - Junos PE - CE2

Please find the outputs
R1#sh mpls ldp neighbor
    Peer LDP Ident: 20.20.20.20:0; Local LDP Ident 212.118.1.1:0
        TCP connection: 20.20.20.20.646 - 212.118.1.1.23711
        State: Oper; Msgs sent/rcvd: 111/92; Downstream
        Up time: 00:14:39
        LDP discovery sources:
          FastEthernet1/0, Src IP addr: 212.118.201.20
          Targeted Hello 212.118.1.1 -> 20.20.20.20, active, passive
        Addresses bound to peer LDP Ident:
          20.20.20.20     212.118.201.20

root# run show l2circuit connections
Layer-2 Circuit Connections:

Legend for connection status (St)
EI -- encapsulation invalid      NP -- interface h/w not present
MM -- mtu mismatch               Dn -- down
EM -- encapsulation mismatch     VC-Dn -- Virtual circuit Down
CM -- control-word mismatch      Up -- operational
VM -- vlan id mismatch           CF -- Call admission control failure
OL -- no outgoing label          IB -- TDM incompatible bitrate
NC -- intf encaps not CCC/TCC    TM -- TDM misconfiguration
BK -- Backup Connection          ST -- Standby Connection
CB -- rcvd cell-bundle size bad  SP -- Static Pseudowire
LD -- local site signaled down   RS -- remote site standby
RD -- remote site signaled down  XX -- unknown

Legend for interface status
Up -- operational
Dn -- down
Neighbor: 212.118.1.1
    Interface                 Type  St     Time last up          # Up trans
    em1.45(vc 45)             rmt   Up     Aug 20 11:15:25 2015           1
      Remote PE: 212.118.1.1, Negotiated control-word: No
      Incoming label: 299776, Outgoing label: 18
      Negotiated PW status TLV: No
      Local interface: em1.45, Status: Up, Encapsulation: VLAN

Now , what I have noticed is the MTU on the interfaces (and I think that is
why I cannot ping between the CEs)

R1#show mpls interfaces fastEthernet 1/0 detail | inc MTU
        MTU = 1500

R1#sh int f1/1 | inc MTU
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

F1/0 connected to Junos and F1/1 connected to CE

root# run show interfaces em0 | match MTU
  Type: Ethernet, Link-level type: Ethernet, MTU: 1514, Speed: 1000mbps
    Protocol inet, MTU: 1500
    Protocol mpls, MTU: 1500, Maximum labels: 3
      Flags: Is-Primary, User-MTU

[edit]
root# run show interfaces em1 | match MTU
  Type: Ethernet, Link-level type: Ethernet, MTU: 1518, Speed: 1000mbps
    Protocol ccc, MTU: 1518

root# show interfaces em0 | display set
set interfaces em0 unit 0 family inet address 212.118.201.20/24
set interfaces em0 unit 0 family mpls mtu 1500

BR,
Mohammad

On Tue, Aug 11, 2015 at 4:34 PM, Mohammad Khalil <eng.m...@gmail.com> wrote:

> Hi , the issue is that I cannot ask the SP to change his router-id neither
> do I can from my side as I have many active sessions
> The issue am trying to resolve now is even if the MPLS LDP neighbor became
> up , the targeted LDP session is passive !
> I have tried to change many parameters from my side (Cisco side) with no
> luck
> When I tested the same setup between Cisco devices , I had no issue and I
> could ping end to end (between the CEs)
>
> R1#show mpls ldp neighbor
>     Peer LDP Ident: 20.20.20.20:0; Local LDP Ident 1.1.1.1:0
>         TCP connection: 20.20.20.20.646 - 212.118.1.1.24988
>         State: Oper; Msgs sent/rcvd: 91/77; Downstream
>         Up time: 00:12:18
>         LDP discovery sources:
>           FastEthernet1/0, Src IP addr: 212.118.201.20
> *          Targeted Hello 212.118.1.1 -> 20.20.20.20, passive*
>         Addresses bound to peer LDP Ident:
>           20.20.20.20     212.118.201.20
>
>
> On Mon, Aug 10, 2015 at 7:59 PM, Gabriel Farias <gabrielfaria...@gmail.com
> > wrote:
>
>> Hi Mohammad,
>>
>> I made the setting on the Junos using different transport-address in the
>> LDP, but the exit "show ldp interface" see ID as the public address. I'm
>> not sure is working, you also observed this behavior?
>>
>> {master}[edit]
>> admin@RT1000LAB# show interfaces lo0
>> unit 0 {
>>     family inet {
>>         address 1.1.1.1/32 {  >>>>>>>>>>>>>>>>>>>>> Private ip address
>>             primary;
>>         }
>>         address 30.30.30.30/32; >>>>>>>>>>>>>>>>>>>>> Public ip address
>>     }
>> }
>>
>> {master}[edit]
>> admin@RT1000LAB# show routing-options router-id
>> router-id 30.30.30.30;
>>
>> {master}[edit]
>> admin@RT1000LAB# show protocols ldp
>> transport-address 1.1.1.1;
>>
>> {master}[edit]
>> admin@RT1000LAB# run show ldp interface
>> Interface            Label space ID        Nbr count   Next hello
>> lo0.0                30.30.30.30:0           0           0
>> ge-0/0/0.0           30.30.30.30:0           1           1
>> fe-1/2/0.0           30.30.30.30:0           1           3
>>
>> Regards,
>> Gabriel Farias
>>
>> 2015-08-10 3:46 GMT-03:00 Mohammad Khalil <eng.m...@gmail.com>:
>>
>>> *Cisco Side*
>>>
>>> *interface Loopback0*
>>>
>>> *ip address 1.1.1.1 255.255.255.255*
>>>
>>>
>>>
>>> *interface Loopback1*
>>>
>>> *ip address 212.118.1.1 255.255.255.255*
>>>
>>>
>>>
>>> *mpls label protocol ldp*
>>>
>>> *mpls ldp router-id Loopback0 force*
>>>
>>>
>>>
>>> *interface FastEthernet1/0*
>>>
>>> *ip address 212.118.201.1 255.255.255.0*
>>>
>>> *mpls ldp discovery transport-address 212.118.1.1*
>>>
>>> *mpls ip*
>>>
>>>
>>>
>>> *router bgp 1*
>>>
>>> *bgp log-neighbor-changes*
>>>
>>> *no bgp default ipv4-unicast*
>>>
>>> *neighbor 212.118.201.20 remote-as 20*
>>>
>>> *address-family ipv4*
>>>
>>> *  network 212.118.1.1 mask 255.255.255.255*
>>>
>>> *  neighbor 212.118.201.20 activate*
>>>
>>> *  neighbor 212.118.201.20 send-label*
>>>
>>> *exit-address-family*
>>>
>>> *address-family l2vpn vpls*
>>>
>>> *  neighbor 212.118.201.20 activate*
>>>
>>> *  neighbor 212.118.201.20 send-community both*
>>>
>>> *  neighbor 212.118.201.20 prefix-length-size 2*
>>>
>>> *exit-address-family*
>>>
>>>
>>>
>>> *Juniper Side*
>>>
>>>
>>>
>>> *set interfaces em0 unit 0 family inet address 212.118.201.20/24
>>> <http://212.118.201.20/24>*
>>>
>>> *set interfaces em0 unit 0 family mpls*
>>>
>>>
>>>
>>> *set interfaces lo0 unit 0 family inet address 20.20.20.20/32
>>> <http://20.20.20.20/32>*
>>>
>>>
>>>
>>> *set routing-options router-id 20.20.20.20*
>>>
>>> *set routing-options autonomous-system 20*
>>>
>>>
>>>
>>> *set protcols bgp group EBGP local-address 212.118.201.20*
>>>
>>> *set protcols bgp group EBGP family inet labeled-unicast*
>>>
>>> *set protcols bgp group EBGP l2vpn signaling*
>>>
>>> *set protcols bgp group EBGP export MSSK_POL*
>>>
>>> *set protcols bgp group EBGP peer-as 1*
>>>
>>> *set protcols bgp group EBGP neighbor 212.118.201.1*
>>>
>>>
>>>
>>> *set protocols ldp transport-address router-id*
>>>
>>>
>>>
>>> *set policy-options prefix-list MSSK_LIST 20.20.20.20/32
>>> <http://20.20.20.20/32>*
>>>
>>>
>>>
>>> *set policy-options policy-statement MSSK_POL from prefix-list MSSK_LIST*
>>>
>>> *set policy-options policy-statement MSSK_POL then accept*
>>>
>>>
>>>
>>> *Verifications*
>>>
>>> R1#show mpls interfaces
>>>
>>> Interface              IP            Tunnel   BGP Static Operational
>>>
>>> *FastEthernet1/0        Yes (ldp)     No       Yes No     Yes*
>>>
>>> FastEthernet2/0        Yes (ldp)     No       No  No     Yes
>>>
>>>
>>>
>>> R1#show ip bgp summary
>>>
>>> BGP router identifier 212.118.1.1, local AS number 1
>>>
>>> BGP table version is 15, main routing table version 15
>>>
>>> 2 network entries using 288 bytes of memory
>>>
>>> 2 path entries using 160 bytes of memory
>>>
>>> 2/2 BGP path/bestpath attribute entries using 272 bytes of memory
>>>
>>> 1 BGP AS-PATH entries using 24 bytes of memory
>>>
>>> 0 BGP route-map cache entries using 0 bytes of memory
>>>
>>> 0 BGP filter-list cache entries using 0 bytes of memory
>>>
>>> BGP using 744 total bytes of memory
>>>
>>> BGP activity 3/1 prefixes, 8/6 paths, scan interval 60 secs
>>>
>>>
>>>
>>> Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ
>>> Up/Down  State/PfxRcd
>>>
>>> 212.118.201.20  4           20      31      34       15    0    0
>>> 00:12:47        1
>>>
>>>
>>>
>>> R1#show ip bgp
>>>
>>> BGP table version is 15, local router ID is 212.118.1.1
>>>
>>> Status codes: s suppressed, d damped, h history, * valid, > best, i -
>>> internal,
>>>
>>>               r RIB-failure, S Stale, m multipath, b backup-path, f
>>> RT-Filter,
>>>
>>>               x best-external, a additional-path, c RIB-compressed,
>>>
>>> Origin codes: i - IGP, e - EGP, ? - incomplete
>>>
>>> RPKI validation codes: V valid, I invalid, N Not found
>>>
>>>
>>>
>>>      Network          Next Hop            Metric LocPrf Weight Path
>>>
>>> *>  20.20.20.20/32   212.118.201.20                         0 20 i
>>>
>>> *>  212.118.1.1/32   0.0.0.0                  0         32768 i
>>>
>>>
>>>
>>> R1#sh bgp l2vpn vpls all summary
>>>
>>> BGP router identifier 212.118.1.1, local AS number 1
>>>
>>> BGP table version is 1, main routing table version 1
>>>
>>>
>>>
>>> Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ
>>> Up/Down  State/PfxRcd
>>>
>>> 212.118.201.20  4           20      32      35        1    0    0
>>> 00:13:15        0
>>>
>>>
>>>
>>> R1#show mpls ldp neighbor
>>>
>>>     Peer LDP Ident: 2.2.2.2:0; Local LDP Ident 1.1.1.1:0
>>>
>>>         TCP connection: 2.2.2.2.26760 - 1.1.1.1.646
>>>
>>>         State: Oper; Msgs sent/rcvd: 71/63; Downstream
>>>
>>>         Up time: 00:50:34
>>>
>>>         LDP discovery sources:
>>>
>>>           FastEthernet2/0, Src IP addr: 192.168.12.2
>>>
>>>         Addresses bound to peer LDP Ident:
>>>
>>>           192.168.12.2    2.2.2.2
>>>
>>> *    Peer LDP Ident: 20.20.20.20:0 <http://20.20.20.20:0>; Local LDP
>>> Ident 1.1.1.1:0 <http://1.1.1.1:0>*
>>>
>>>         TCP connection: 20.20.20.20.646 - *212.118.1.1*.11719
>>>
>>>         State: Oper; Msgs sent/rcvd: 211/180; Downstream
>>>
>>>         Up time: 00:29:28
>>>
>>>         LDP discovery sources:
>>>
>>>           FastEthernet1/0, Src IP addr: 212.118.201.20
>>>
>>>         Addresses bound to peer LDP Ident:
>>>
>>>           212.118.201.20
>>>
>>> On Mon, Aug 10, 2015 at 3:48 AM, gabrielfarias <
>>> gabrielfaria...@gmail.com> wrote:
>>>
>>>> Hi Mohammad,
>>>>
>>>> I am a member of juniper-nsp list and you recently wrote about the
>>>> issue of router-id for LDP, I had a similar question, I was wondering if
>>>> you solved and how did it?
>>>>
>>>> In my case I used two router-id with a global public address and other
>>>> private address to LDP, using the transport-address the Junos feature.
>>>>
>>>>
>>>> http://www.juniper.net/documentation/en_US/junos14.2/topics/usage-guidelines/mpls-specifying-the-transport-address-used-by-ldp.html
>>>>
>>>> Regards,
>>>> Gabriel Farias
>>>>
>>>
>>>
>>
>
_______________________________________________
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp

Reply via email to