ahmadsamir added inline comments.

INLINE COMMENTS

> dhaumann wrote in katedocument.h:827
> I dislike the double negation: noIndentation = false. Later even 
> !noIndentation. This is bad API design.
> 
> Please change to bool indent = true.

Noted. Although I'll use an enum per cullmann's recommendation (but I'll choose 
a better name, hopefully).

(Believe it or not, I had it as "const bool indent" first, but then bike-shed 
it to an over-engineered death).

> cullmann wrote in kateview.cpp:2881
> I assume this is just copied from the normal
> 
> void KTextEditor::ViewPrivate::keyReturn()
> {
> 
>   doc()->newLine(this);
>   m_viewInternal->iconBorder()->updateForCursorLineChange();
>   m_viewInternal->updateView();
> 
> }
> 
> ;=) In doubt I would just keep this as is and one can think separately if 
> that is needed in both places.

Correct. My reasoning was, it's exactly like keyReturn(), but with a different 
newLine() call, (i.e. someone else invented the wheel I just pushed in a 
different direction, so to speak).

As for updateForCursorLineChange(), digging around in git history I found 
this[1], so I guess it's needed.

Setting the cursor position and begin/endEdit are handled by 
DocumentPrivate::newLine().

[1]https://bugs.kde.org/show_bug.cgi?id=340363

REPOSITORY
  R39 KTextEditor

REVISION DETAIL
  https://phabricator.kde.org/D22276

To: ahmadsamir, #ktexteditor, cullmann, dhaumann
Cc: bruns, mickaelbo, kde-frameworks-devel, kwrite-devel, LeGast00n, domson, 
michaelh, ngraham, demsking, cullmann, sars, dhaumann

Reply via email to