Avi Kivity wrote:
> I generally understand "irq" to mean the interrupt request line, and 
> "interrupt" to mean a vectored interrupt (post interrupt controller).  
> In those terms the naming in correct.  However I'm not at all certain 
> this naming convention is generally accepted.
I think on s390 we'll have

kvm_s390_vcpu_has_extint()
kvm_s390_vcpu_has_ioint()
and maybe
kvm_s390_vcpu_has_machine_check()

and kvm_arch_vcpu_has_interrupt() will check if any of above is 
pending. It would be great if the function names would clearly 
identify that one is the general portable "cpu needs to run an 
interrupt handler of whatever sort" and the other one is "we have a 
vectored interrupt to deliver" on x86 as well. If you'd like to keep 
the wording as is, I'll send a patch that just adds the 
kvm_arch_cpu_has_interrupt wrapper.

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
kvm-devel mailing list
kvm-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/kvm-devel

Reply via email to