Am 07.02.2010 um 13:29 schrieb Avi Kivity <a...@redhat.com>:

On 02/04/2010 05:55 PM, Alexander Graf wrote:
Right now MMIO access can only happen for GPRs and is at most 32 bit wide.
That's actually enough for almost all types of hardware out there.

Unfortunately, the guest I was using used FPU writes to MMIO regions, so
it ended up writing 64 bit MMIOs using FPRs and QPRs.

So let's add code to handle those odd cases too.

Signed-off-by: Alexander Graf<ag...@suse.de>
---
 arch/powerpc/include/asm/kvm.h     |    7 +++++++
 arch/powerpc/include/asm/kvm_ppc.h |    2 +-
 arch/powerpc/kvm/powerpc.c         |   24 ++++++++++++++++++++++--
 3 files changed, 30 insertions(+), 3 deletions(-)

diff --git a/arch/powerpc/include/asm/kvm.h b/arch/powerpc/include/ asm/kvm.h
index 81f3b0b..548376c 100644
--- a/arch/powerpc/include/asm/kvm.h
+++ b/arch/powerpc/include/asm/kvm.h
@@ -77,4 +77,11 @@ struct kvm_debug_exit_arch {
 struct kvm_guest_debug_arch {
 };

+#define REG_MASK    0x001f
+#define REG_EXT_MASK    0xffe0
+#define REG_GPR        0x0000
+#define REG_FPR        0x0020
+#define REG_QPR        0x0040
+#define REG_FQPR    0x0060


These names seem too generic to belong in asm/kvm.h - some application could use the same names. Please add a KVM_ prefix.

Yes, will do.

Alex
--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to