On Fri, Jul 17, 2015 at 18:13:25 +0200, Andrea Bolognani wrote: > The new name makes it clear that the returned bitmap contains the > information about which CPUs are online, not eg. which CPUs are > present. > > Change the name of the out parameter from max_id, which didn't > reflect the actual value returned, to size. Update the error > message as well. > > No functional changes. > --- > src/libvirt_private.syms | 2 +- > src/nodeinfo.c | 12 ++++++------ > src/nodeinfo.h | 4 ++-- > 3 files changed, 9 insertions(+), 9 deletions(-) >
> diff --git a/src/nodeinfo.c b/src/nodeinfo.c > index 7aecc8f..44983b8 100644 > --- a/src/nodeinfo.c > +++ b/src/nodeinfo.c > @@ -1325,8 +1325,8 @@ nodeGetPresentCPUBitmap(const char *sysfs_prefix > ATTRIBUTE_UNUSED, > } > > virBitmapPtr > -nodeGetCPUBitmap(const char *sysfs_prefix ATTRIBUTE_UNUSED, > - int *max_id ATTRIBUTE_UNUSED) > +nodeGetOnlineCPUBitmap(const char *sysfs_prefix ATTRIBUTE_UNUSED, > + int *size ATTRIBUTE_UNUSED) Same comment for the second parameter name as in the previous patch. ACK to the function name change. Peter
signature.asc
Description: Digital signature
-- libvir-list mailing list libvir-list@redhat.com https://www.redhat.com/mailman/listinfo/libvir-list