Either would be the "purely stdlib" way to go, and Naftoli is right
that it would be a lot more verbose.  I would argue that the
difference isn't *so* substantial if you sprinkle in a type alias and
some implicit conversions (so that you can map/flatMap/filter over
something of type Either[Option[A], String]).

I am aware of the Failure case, and that's why I argue that Box
*isn't* a drop-in Option replacement.  API naming differences are
inconsequential, but adding another case to the ADT is a pretty
dramatic difference.  However, Lift seems to use Box *everywhere*,
even in places where it is only using it as if it were Option.

Daniel

On Feb 26, 1:17 am, Heiko Seeberger <heiko.seeber...@googlemail.com>
wrote:
> On 26 February 2010 08:09, Naftoli Gugenheim <naftoli...@gmail.com> wrote:
>
> > Either -- but it's more verbose.
> > I'm not so sure David will want to rewrite the entire lift anyway...
>
> Right now, I only would like to listen to Daniel, OK?
>
> Heiko
>
> Company: weiglewilczek.com
> Blog: heikoseeberger.name
> Follow me: twitter.com/hseeberger
> OSGi on Scala: scalamodules.org
> Lift, the simply functional web framework: liftweb.net

-- 
You received this message because you are subscribed to the Google Groups 
"Lift" group.
To post to this group, send email to lift...@googlegroups.com.
To unsubscribe from this group, send email to 
liftweb+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/liftweb?hl=en.

Reply via email to