Looks basically good, I just have some trivial quibbles.  This should
vastly simplify debugging doc problems, though!


http://codereview.appspot.com/5645046/diff/1/Documentation/GNUmakefile
File Documentation/GNUmakefile (right):

http://codereview.appspot.com/5645046/diff/1/Documentation/GNUmakefile#newcode198
Documentation/GNUmakefile:198:
$(top-src-dir)/scripts/build/CheckAndRun.sh "$(MAKEINFO) -I$(src-dir)
-I$(outdir) --output=$@ $<"  "$*.makeinfo.log"
Could this be condensed into
$(RUN_WITH_LOG)
or something like that?  i.e. define
RUN_WITH_LOG = $(top-src-dir)/scripts/build/CheckAndRun.sh
somewhere in a "main" build file (maybe stepmake.make?) and then just
call that definition everywhere else?

http://codereview.appspot.com/5645046/diff/1/scripts/build/CheckAndRun.sh
File scripts/build/CheckAndRun.sh (right):

http://codereview.appspot.com/5645046/diff/1/scripts/build/CheckAndRun.sh#newcode3
scripts/build/CheckAndRun.sh:3: # CheckAndRun.sh.  Takes 2 parameters -
the command to be run and
sorry, totally silly complaint, but I wince every time I see this: unix
people are generally allergic to Capital letters.  Maybe because it
requires pressing shift, and the whole point of the command-line is to
be lazy?

Could this be check_and_run.sh or check-and-run.sh ?  I think that would
fit in with other scripts/build/* items as well.

Also, technically I'd call it run-and-check.sh, since it runs the
command first, and then checks the results afterwards.

http://codereview.appspot.com/5645046/

_______________________________________________
lilypond-devel mailing list
lilypond-devel@gnu.org
https://lists.gnu.org/mailman/listinfo/lilypond-devel

Reply via email to