On Aug 19, 2013 11:36 PM, "Andrew Bernard" <andrew.bern...@gmail.com> wrote:
>> They take up space but don't /do/ anything in
>> return for the extra finger effort.
>
> But they _do_ do something in Nederlands for people whose language it is.

Sure, but I was responding to a comment from a native English speaker who
uses Dutch input because... he likes more typing? :-P

Kidding... the real issue is the trade-off between readability and
concision. Actually, despite my complaints about extra keystrokes, in my
SuperCollider coding, I'm coming to favor readability: naming a variable
pitchClass rather than pc, or compare these ways to make an array of random
numbers:

{ 10.rand } ! 20  // "!"? What's that?

vs

// Even if I don't know anything about SC,
// this is obviously about arrays so I know
// where to look in the help
Array.fill(20, { 10.rand })

In the latter case, SC's code editor has nice auto-completion features, so
the finger cost is not as high as the character count.

For accidentals, df and des are both abbreviations -- favoring concision --
but one is more concise than the other, and neither is inherently more
readable. Of course it's valuable to let users enter notes in the way that
looks comfortable to them, but I think here, there's a rational argument to
be made that the gain in ease of reading is small.

But anyway, with Frescobaldi, I can type \inc RET SPC "eng RET " so, easy
enough.

If we wanted efficiency and global readability, we might try db and d#, but
I guess the # would confuse the parser.

hjh
_______________________________________________
lilypond-user mailing list
lilypond-user@gnu.org
https://lists.gnu.org/mailman/listinfo/lilypond-user

Reply via email to