Hello list,

I've been trying to create several choral scores using the same
template, but sometimes I need to change just a small part of the
template, so I end up copying the original and naming it style_two.ily
or style_piecename.ily etc. For example, in one piece I need to shrink
the PianoStaff and reduce the basic-distance for a 'rehearsal piano'
sort of look, and in another I need a full sized PianoStaff for a real
keyboard accompaniment.

To simplify the process, I've been trying to split up the 'style' into
chunks (i.e. margins, paper size, ragged or not, fonts, vertical
spacing, etc. in the paper block; lyric tweaks, pianostaff shrinking
for rehearsal piano, etc in the layout block), but it seems I can't
combine the chunks into one scope.

When I try to compile the snippet below, I get

error: syntax error, unexpected OUTPUT_DEF_IDENTIFIER
  \choralOctavoMargins

%%%%%%%
\version "2.18.2"

choralOctavoDimensions = \paper { paper-height = 10.5\in }
choralOctavoMargins = \paper { top-margin = 0.5\in }

\paper { \choralOctavoDimensions \choralOctavoMargins }
\score { \new Voice { a' b' c'' d'' } }
%%%%%%%

It works if I remove one of the two variables, but combined, it will
not work. I'm having the same issue when trying to combine in the
\layout scope.

Is what I'm trying to do possible? It seems to me that my lack of
knowledge about scoping syntax is what is giving me trouble.

Thanks in advance,
Samuel.

_______________________________________________
lilypond-user mailing list
lilypond-user@gnu.org
https://lists.gnu.org/mailman/listinfo/lilypond-user

Reply via email to