Hi Anthony,

In looking this over quickly, I found one optimization, one warning, and one nigley:

Optimization: In your "on Animation" you have a line that says:

if pnCurrentMem > plMembers.count then

This will call the count routine EVERY time. Instead, create a new property, e.g., pnMembers, set it in your "on PlayAnimation" method when you get a new list of animation members, and use it in the test above.


Warning: In the "on PlayAnimation" routine, you have a line:


plMembers = lMembers

Lists are passed by reference. Therefore, if the routine that starts the animation by calling this routine changes its version of this list, even after it returns from this call, the list in your behavior will be changed. This potential problem can be avoided (unless it's done on purpose this way), by changing the above line to:

plMembers = duplicate(lMembers)


Nigley: In your stopAnimation routine, you have a parameter variable called bResetMem. But you since you are comparing it to symbols (#original and #first) it should really be called yResetMem according to your naming convention.


Other than that it looks clean.

Irv


At 11:07 AM -0500 5/14/04, Anthony W. Fouts, Jr. wrote:


Here is the actual animation behavior I am optimizing.

http://www.lifelinestudios.com/sAnimationSequential.htm



--

Multimedia Wrangler.

[To remove yourself from this list, or to change to digest mode, go to http://www.penworks.com/lingo-l.cgi To post messages to the list, email [EMAIL PROTECTED] (Problems, email [EMAIL PROTECTED]). Lingo-L is for learning and helping with programming Lingo. Thanks!]

Reply via email to