On Tue 22 Dec 06:31 PST 2015, Linus Walleij wrote:

> As we want gpio_chip .get() calls to be able to return negative
> error codes and propagate to drivers, we need to go over all
> drivers and make sure their return values are clamped to [0,1].
> We do this by using the ret = !!(val) design pattern.
> 
> Also, this code was double-inverting a bool. That makes no
> sense whatsoever, so I removed the double-invert.
> 
> Cc: Björn Andersson <bjorn.anders...@sonymobile.com>
> Signed-off-by: Linus Walleij <linus.wall...@linaro.org>
> ---
>  drivers/pinctrl/qcom/pinctrl-ssbi-gpio.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/pinctrl/qcom/pinctrl-ssbi-gpio.c 
> b/drivers/pinctrl/qcom/pinctrl-ssbi-gpio.c
> index 7bea0df06fb1..394ca34bec4a 100644
> --- a/drivers/pinctrl/qcom/pinctrl-ssbi-gpio.c
> +++ b/drivers/pinctrl/qcom/pinctrl-ssbi-gpio.c
> @@ -487,10 +487,10 @@ static int pm8xxx_gpio_get(struct gpio_chip *chip, 
> unsigned offset)

                ret = pin->output_value;

I do make sure that output_value always is [0,1], but feel free to add a
!! for clarity.

>       } else {
>               ret = irq_get_irqchip_state(pin->irq, IRQCHIP_STATE_LINE_LEVEL, 
> &state);
>               if (!ret)
> -                     ret = !!state;
> +                     ret = state;
>       }
>  
> -     return ret;
> +     return !!ret;

But these you should keep as is; before your change ret is either
negative errno or !!state, after your change errno is merged with the
"high case".

So either just drop this patch, or add the !! to the output_value and my
Reviewed-by if you want consistency.


This is actually the code path that started the discussion :)

Regards,
Bjorn

>  }
>  
>  static void pm8xxx_gpio_set(struct gpio_chip *chip, unsigned offset, int 
> value)
> -- 
> 2.4.3
> 
> --
> To unsubscribe from this list: send the line "unsubscribe linux-gpio" in
> the body of a message to majord...@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
--
To unsubscribe from this list: send the line "unsubscribe linux-gpio" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to