On Thu, Dec 10, 2015 at 04:14:18PM -0800, K. Y. Srinivasan wrote:
> +     ret = vmbus_sendpacket(device->channel, vstor_packet,
> +                            (sizeof(struct vstor_packet) -
> +                            vmscsi_size_delta),
> +                            (unsigned long)request,
> +                            VM_PKT_DATA_INBAND,
> +                            VMBUS_DATA_PACKET_FLAG_COMPLETION_REQUESTED);
> +
> +     if (ret != 0)
> +             goto cleanup;
> +
> +     t = wait_for_completion_timeout(&request->wait_event, 5*HZ);
> +     if (t == 0) {
> +             ret = -ETIMEDOUT;
> +             goto cleanup;
> +     }
> +
> +     if (vstor_packet->operation != VSTOR_OPERATION_COMPLETE_IO ||
> +         vstor_packet->status != 0)
> +             goto cleanup;

"cleanup" is a misleading name because it doesn't clean up anything.
Do nothing gotos are a pain in the butt and they always introduce bugs.
For example, you appear to have forgotten to set the error code.  But
because it's a do-nothing goto it's ambiguous so perhaps returning
success was intended.

Empirically this style of coding causes bugs.  It does not prevent them.
It is a bad style if you believe in measuring, evidence and science.

regards,
dan carpenter

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to