On Fri, Jan 01, 2016 at 10:59:08PM +0800, Geliang Tang wrote:
> Use to_delayed_work() instead of open-coding it.
> 
> Signed-off-by: Geliang Tang <geliangt...@163.com>

Applied, thank you.

> ---
>  drivers/input/touchscreen/pcap_ts.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/input/touchscreen/pcap_ts.c 
> b/drivers/input/touchscreen/pcap_ts.c
> index 23a354a..0e3fc41 100644
> --- a/drivers/input/touchscreen/pcap_ts.c
> +++ b/drivers/input/touchscreen/pcap_ts.c
> @@ -87,7 +87,7 @@ static void pcap_ts_read_xy(void *data, u16 res[2])
>  
>  static void pcap_ts_work(struct work_struct *work)
>  {
> -     struct delayed_work *dw = container_of(work, struct delayed_work, work);
> +     struct delayed_work *dw = to_delayed_work(work);
>       struct pcap_ts *pcap_ts = container_of(dw, struct pcap_ts, work);
>       u8 ch[2];
>  
> -- 
> 2.5.0
> 
> 

-- 
Dmitry
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to