Use to_delayed_work() instead of open-coding it.

Signed-off-by: Geliang Tang <geliangt...@163.com>
---
 drivers/char/xillybus/xillybus_core.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/drivers/char/xillybus/xillybus_core.c 
b/drivers/char/xillybus/xillybus_core.c
index 77d6c12..3bd36e0 100644
--- a/drivers/char/xillybus/xillybus_core.c
+++ b/drivers/char/xillybus/xillybus_core.c
@@ -1164,8 +1164,7 @@ static int xillybus_flush(struct file *filp, fl_owner_t 
id)
 
 static void xillybus_autoflush(struct work_struct *work)
 {
-       struct delayed_work *workitem = container_of(
-               work, struct delayed_work, work);
+       struct delayed_work *workitem = to_delayed_work(work);
        struct xilly_channel *channel = container_of(
                workitem, struct xilly_channel, rd_workitem);
        int rc;
-- 
2.5.0


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to