On Tue, May 31, 2016 at 02:42:21PM -0700, Megha Dey wrote:
>
> @@ -416,8 +421,8 @@ static void mcryptd_hash_finup(struct 
> crypto_async_request *req_async, int err)
>  
>       if (unlikely(err == -EINPROGRESS))
>               goto out;
> -
> -     err = shash_ahash_mcryptd_finup(req, &rctx->desc);
> +     rctx->out = req->result;
> +     err = shash_ahash_mcryptd_finup(req, &rctx->areq);

These shash_ahash functions should be renamed.

Also why are they exported?

> @@ -439,17 +444,18 @@ static int mcryptd_hash_finup_enqueue(struct 
> ahash_request *req)
>  static void mcryptd_hash_digest(struct crypto_async_request *req_async, int 
> err)
>  {
>       struct mcryptd_hash_ctx *ctx = crypto_tfm_ctx(req_async->tfm);
> -     struct crypto_shash *child = ctx->child;
> +     struct crypto_ahash *child = ctx->child;
>       struct ahash_request *req = ahash_request_cast(req_async);
>       struct mcryptd_hash_request_ctx *rctx = ahash_request_ctx(req);
> -     struct shash_desc *desc = &rctx->desc;
> +     struct ahash_request *desc = &rctx->areq;
> +     struct crypto_async_request *base = &desc->base;
>  
>       if (unlikely(err == -EINPROGRESS))
>               goto out;
> +     base->tfm = &child->base;
> +     base->flags = CRYPTO_TFM_REQ_MAY_SLEEP;  /* check this again */

You should not be touching crypto_async_request directly.  Use
the proper ahash interface to set the child request.

Thanks,
-- 
Email: Herbert Xu <herb...@gondor.apana.org.au>
Home Page: http://gondor.apana.org.au/~herbert/
PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt

Reply via email to