Rename the platform driver name from "stm" to "stm32-display"
for a better readability in /sys/bus/platform/drivers entries.

Note: We keep "stm" as drm_driver.name because it is better
when using "modetest -M stm ..." (even if recent modetest patch
avoids using -M).

Signed-off-by: Philippe CORNU <philippe.co...@st.com>
---
 drivers/gpu/drm/stm/drv.c | 21 +++++++--------------
 1 file changed, 7 insertions(+), 14 deletions(-)

diff --git a/drivers/gpu/drm/stm/drv.c b/drivers/gpu/drm/stm/drv.c
index 83ab48f..095971f 100644
--- a/drivers/gpu/drm/stm/drv.c
+++ b/drivers/gpu/drm/stm/drv.c
@@ -20,13 +20,6 @@
 
 #include "ltdc.h"
 
-#define DRIVER_NAME            "stm"
-#define DRIVER_DESC            "STMicroelectronics SoC DRM"
-#define DRIVER_DATE            "20170330"
-#define DRIVER_MAJOR           1
-#define DRIVER_MINOR           0
-#define DRIVER_PATCH_LEVEL     0
-
 #define STM_MAX_FB_WIDTH       2048
 #define STM_MAX_FB_HEIGHT      2048 /* same as width to handle orientation */
 
@@ -59,12 +52,12 @@ static void drv_lastclose(struct drm_device *ddev)
        .driver_features = DRIVER_MODESET | DRIVER_GEM | DRIVER_PRIME |
                           DRIVER_ATOMIC,
        .lastclose = drv_lastclose,
-       .name = DRIVER_NAME,
-       .desc = DRIVER_DESC,
-       .date = DRIVER_DATE,
-       .major = DRIVER_MAJOR,
-       .minor = DRIVER_MINOR,
-       .patchlevel = DRIVER_PATCH_LEVEL,
+       .name = "stm",
+       .desc = "STMicroelectronics SoC DRM",
+       .date = "20170330",
+       .major = 1,
+       .minor = 0,
+       .patchlevel = 0,
        .fops = &drv_driver_fops,
        .dumb_create = drm_gem_cma_dumb_create,
        .dumb_map_offset = drm_gem_cma_dumb_map_offset,
@@ -206,7 +199,7 @@ static int stm_drm_platform_remove(struct platform_device 
*pdev)
        .probe = stm_drm_platform_probe,
        .remove = stm_drm_platform_remove,
        .driver = {
-               .name = DRIVER_NAME,
+               .name = "stm32-display",
                .of_match_table = drv_dt_ids,
        },
 };
-- 
1.9.1

Reply via email to