On Fri, Jan 05, 2018 at 06:12:23PM -0800, Tim Chen wrote:
> +void unprotected_firmware_begin(void)
> +{
> +     if (firmware_ibrs) {
> +             __disable_indirect_speculation();
> +     } else {
> +             /*
> +              * rmb prevent unwanted speculation when we
> +              * are setting IBRS
> +              */
> +             rmb();
> +     }
> +}
> +EXPORT_SYMBOL_GPL(unprotected_firmware_begin);

What modules need these functions?

And again, if they are needed, we need a better naming scheme for them.
Prefix them all with "firmware_" perhaps to make it a bit nicer?

thanks,

greg k-h

Reply via email to