Le 27/02/2018 à 08:25, Mathieu Malaterre a écrit :
On Mon, Feb 26, 2018 at 3:45 PM, Andy Shevchenko
<andy.shevche...@gmail.com> wrote:
On Mon, Feb 26, 2018 at 4:44 PM, Andy Shevchenko
<andy.shevche...@gmail.com> wrote:
On Sun, Feb 25, 2018 at 7:22 PM, Mathieu Malaterre <ma...@debian.org> wrote:

  static void __init check_cpu_feature_properties(unsigned long node)
  {
-       unsigned long i;
         struct feature_property *fp = feature_properties;
         const __be32 *prop;


Much simpler is just add

if (ARRAY_SIZE() == 0)
  return;

-       for (i = 0; i < ARRAY_SIZE(feature_properties); ++i, ++fp) {
+       for (; fp != feature_properties + ARRAY_SIZE(feature_properties); ++fp) 
{

...or convert to while(), which will be more readable.

So you'd prefer something like:

while (fp < feature_properties + ARRAY_SIZE(feature_properties)) {
   ...
   ++fp;
}

right ?



Why not do as suggested by Segher, ie just replace < by != in the original form ?
Or add in front:
if (!ARRAY_SIZE(feature_properties))
        return;

Christophe

Reply via email to