In make_dentry_ptr_block, it is confused with "&" for t->dentry_bitmap
but without "&" for t->dentry, so delete "&" to make code more readable.

Signed-off-by: Yunlong Song <yunlong.s...@huawei.com>
---
 fs/f2fs/f2fs.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/fs/f2fs/f2fs.h b/fs/f2fs/f2fs.h
index 191ee57..474b9e9 100644
--- a/fs/f2fs/f2fs.h
+++ b/fs/f2fs/f2fs.h
@@ -471,7 +471,7 @@ static inline void make_dentry_ptr_block(struct inode 
*inode,
        d->inode = inode;
        d->max = NR_DENTRY_IN_BLOCK;
        d->nr_bitmap = SIZE_OF_DENTRY_BITMAP;
-       d->bitmap = &t->dentry_bitmap;
+       d->bitmap = t->dentry_bitmap;
        d->dentry = t->dentry;
        d->filename = t->filename;
 }
-- 
1.8.5.2

Reply via email to