On 12/06/18 22:09, Chris Opperman wrote:
Changes since v3:
a) Reverted u64 to unsigned long long and u32 to unsigned int.
b) Added patch versioning.
c) Changed type of scans_left to unsigned long long to avoid cast.
d) Clarified and updated changelog.

8-----------------------------------------------------------------------8<

Improve readability of comedi_nsamples_left:
a) Reduce nesting by using more return statements.
b) Declare variables scans_left and samples_left at start of function.
c) Change type of scans_Left to unsigned long long to avoid cast.

Signed-off-by: Chris Opperman <eklikeroo...@gmail.com>
---
  drivers/staging/comedi/drivers.c | 26 +++++++++++++-------------
  1 file changed, 13 insertions(+), 13 deletions(-)

diff --git a/drivers/staging/comedi/drivers.c b/drivers/staging/comedi/drivers.c
index 9d73347..57dd63d 100644
--- a/drivers/staging/comedi/drivers.c
+++ b/drivers/staging/comedi/drivers.c
@@ -473,21 +473,21 @@ unsigned int comedi_nsamples_left(struct comedi_subdevice 
*s,
  {
        struct comedi_async *async = s->async;
        struct comedi_cmd *cmd = &async->cmd;
+       unsigned long long scans_left;
+       unsigned long long samples_left;

-       if (cmd->stop_src == TRIG_COUNT) {
-               unsigned int scans_left = __comedi_nscans_left(s, 
cmd->stop_arg);
-               unsigned int scan_pos =
-                   comedi_bytes_to_samples(s, async->scan_progress);
-               unsigned long long samples_left = 0;
-
-               if (scans_left) {
-                       samples_left = ((unsigned long long)scans_left *
-                                       cmd->scan_end_arg) - scan_pos;
-               }
+       if (cmd->stop_src != TRIG_COUNT)
+               return nsamples;

-               if (samples_left < nsamples)
-                       nsamples = samples_left;
-       }
+       scans_left = __comedi_nscans_left(s, cmd->stop_arg);
+       if (!scans_left)
+               return 0;
+
+       samples_left = scans_left * cmd->scan_end_arg -
+               comedi_bytes_to_samples(s, async->scan_progress);
+
+       if (samples_left < nsamples)
+               return samples_left;
        return nsamples;
  }
  EXPORT_SYMBOL_GPL(comedi_nsamples_left);
--
2.1.4


The code changes look fine. You just need to correct the commit message, as pointed out by Dan Carpenter.

For reference, everything below the "---" cut-off line gets stripped out of the commit message in the git repository, so that is a good place to add comments about the patch itself (such as change logs) that do not belong in the commit message.

--
-=( Ian Abbott <abbo...@mev.co.uk> || Web: www.mev.co.uk )=-
-=( MEV Ltd. is a company registered in England & Wales. )=-
-=( Registered number: 02862268.  Registered address:    )=-
-=( 15 West Park Road, Bramhall, STOCKPORT, SK7 3JZ, UK. )=-

Reply via email to