On Mon, Dec 3, 2018 at 4:17 PM <john.hubb...@gmail.com> wrote: > > From: John Hubbard <jhubb...@nvidia.com> > > Introduces put_user_page(), which simply calls put_page(). > This provides a way to update all get_user_pages*() callers, > so that they call put_user_page(), instead of put_page(). > > Also introduces put_user_pages(), and a few dirty/locked variations, > as a replacement for release_pages(), and also as a replacement > for open-coded loops that release multiple pages. > These may be used for subsequent performance improvements, > via batching of pages to be released. > > This is the first step of fixing the problem described in [1]. The steps > are: > > 1) (This patch): provide put_user_page*() routines, intended to be used > for releasing pages that were pinned via get_user_pages*(). > > 2) Convert all of the call sites for get_user_pages*(), to > invoke put_user_page*(), instead of put_page(). This involves dozens of > call sites, and will take some time. > > 3) After (2) is complete, use get_user_pages*() and put_user_page*() to > implement tracking of these pages. This tracking will be separate from > the existing struct page refcounting. > > 4) Use the tracking and identification of these pages, to implement > special handling (especially in writeback paths) when the pages are > backed by a filesystem. Again, [1] provides details as to why that is > desirable.
I thought at Plumbers we talked about using a page bit to tag pages that have had their reference count elevated by get_user_pages()? That way there is no need to distinguish put_page() from put_user_page() it just happens internally to put_page(). At the conference Matthew was offering to free up a page bit for this purpose. > [1] https://lwn.net/Articles/753027/ : "The Trouble with get_user_pages()" > > Reviewed-by: Jan Kara <j...@suse.cz> Wish, you could have been there Jan. I'm missing why it's safe to assume that a single put_user_page() is paired with a get_user_page()?