> On Jul 28, 2019, at 10:48 AM, Josh Poimboeuf <jpoim...@redhat.com> wrote:
> 
> On Wed, Jul 24, 2019 at 02:05:04PM -0700, Matt Helsley wrote:
>> diff --git a/scripts/Makefile.build b/scripts/Makefile.build
>> index 08b70ee9614a..43707491317c 100644
>> --- a/scripts/Makefile.build
>> +++ b/scripts/Makefile.build
>> @@ -170,22 +170,21 @@ endif
>> 
>> ifdef CONFIG_FTRACE_MCOUNT_RECORD
>> ifndef CC_USING_RECORD_MCOUNT
>> -# compiler will not generate __mcount_loc use recordmcount or 
>> recordmcount.pl
>> -ifdef BUILD_C_RECORDMCOUNT
>> +# compiler will not generate __mcount_loc use objtool mcount record or 
>> recordmcount.pl
> 
> This comment could use some English-ification, something like:
> 
> # The compiler doesn't support generation of the __mcount_loc section.
> # Generate it manually with "objtool mcount record" or recordmcount.pl.

OK, makes sense.

> 
>> @@ -236,9 +235,10 @@ endif # SKIP_STACK_VALIDATION
>> endif # CONFIG_STACK_VALIDATION
>> 
>> # Rebuild all objects when objtool changes, or is enabled/disabled.
>> -objtool_dep = $(objtool_obj)                                        \
>> +objtool_dep += $(objtool_obj)                                       \
>>            $(wildcard include/config/orc/unwinder.h          \
>> -                     include/config/stack/validation.h)
>> +                     include/config/stack/validation.h      \
>> +                     include/config/ftrace/mcount/record.h)
> 
> I think the '+=' isn't needed as this is the only place objtool_dep gets
> set?

Indeed. I think this is  an artifact of the way I initially wrote these changes 
— I tried to eliminate some recordmcount variables by using objtool_dep in the 
recordmcount portions of the Makefile. Then I realized the .config variable 
combinations meant the most clearly-correct way to write it is still with 
separate variables.

Will fix so it’s clear this is the only assignment.

Cheers,
    -Matt

Reply via email to