On 2021/4/1 15:43, Dan Carpenter wrote:
On Thu, Apr 01, 2021 at 11:17:52AM +0800, Yang Yingliang wrote:
Use memdup_user_nul() helper instead of open-coding to
simplify the code.

Reported-by: Hulk Robot <hul...@huawei.com>
Signed-off-by: Yang Yingliang <yangyingli...@huawei.com>
---
  drivers/staging/greybus/camera.c | 13 +++----------
  1 file changed, 3 insertions(+), 10 deletions(-)

diff --git a/drivers/staging/greybus/camera.c b/drivers/staging/greybus/camera.c
index b570e13394ac..2ecdc1bc5092 100644
--- a/drivers/staging/greybus/camera.c
+++ b/drivers/staging/greybus/camera.c
@@ -1120,16 +1120,9 @@ static ssize_t gb_camera_debugfs_write(struct file *file,
        if (len > 1024)
                return -EINVAL;
- kbuf = kmalloc(len + 1, GFP_KERNEL);
-       if (!kbuf)
-               return -ENOMEM;
-
-       if (copy_from_user(kbuf, buf, len)) {
-               ret = -EFAULT;
-               goto done;
-       }
-
-       kbuf[len] = '\0';
+       kbuf = memdup_user_nul(buf, len);
+       if (IS_ERR(kbuf))
+               return PTR_ERR(kbuf);;
                                     ^^
There is an extra semi-colon here.  Checkpatch actually catches this
sort of typo.

I will remove it, and send a v3 later.

Thanks,

Yang


regards,
dan carpenter

.

Reply via email to