Hi David, On Fri, Oct 11, 2024 at 9:31 AM David Gow <david...@google.com> wrote: > From: Luis Felipe Hernandez <luis.hernandez...@gmail.com> > > This patch is a follow-up task from a discussion stemming from point 3 > in a recent patch introducing the int_pow kunit test [1] and > documentation regarding kunit test style and nomenclature [2]. > > Colocate all kunit test suites in lib/math/tests/ and > follow recommended naming convention for files <suite>_kunit.c > and kconfig entries CONFIG_<name>_KUNIT_TEST. > > Link: > https://lore.kernel.org/all/CABVgOS=-vh5TqHFCq_jo=ffq8v_nggr6jspnozag3e6+19y...@mail.gmail.com/ > [1] > Link: https://docs.kernel.org/dev-tools/kunit/style.html [2] > > Signed-off-by: Luis Felipe Hernandez <luis.hernandez...@gmail.com> > Acked-by: Nicolas Pitre <npi...@baylibre.com> > [Rebased on top of mm-nonmm-unstable.] > Signed-off-by: David Gow <david...@google.com>
Thanks for your patch! > --- a/arch/m68k/configs/amiga_defconfig > +++ b/arch/m68k/configs/amiga_defconfig > @@ -619,7 +619,7 @@ CONFIG_KUNIT=m > CONFIG_KUNIT_ALL_TESTS=m > CONFIG_TEST_DHRY=m > CONFIG_TEST_MIN_HEAP=m > -CONFIG_TEST_DIV64=m > +CONFIG_DIV64_KUNIT_TEST=m > CONFIG_REED_SOLOMON_TEST=m > CONFIG_ATOMIC64_SELFTEST=m > CONFIG_ASYNC_RAID6_TEST=m [...] > --- a/lib/Kconfig.debug > +++ b/lib/Kconfig.debug > @@ -2296,7 +2296,7 @@ config TEST_SORT > > If unsure, say N. > > -config TEST_DIV64 > +config DIV64_KUNIT_TEST > tristate "64bit/32bit division and modulo test" > depends on DEBUG_KERNEL || m > help > @@ -2306,7 +2306,7 @@ config TEST_DIV64 > > If unsure, say N. > > -config TEST_MULDIV64 > +config MULDIV64_KUNIT_TEST > tristate "mul_u64_u64_div_u64() test" > depends on DEBUG_KERNEL || m > help This conflicts with "[PATCH] m68k: defconfig: Update defconfigs for v6.12-rc1"[1]. Of course the proper way forward would be to add "default KUNIT_ALL_TESTS" to all tests that still lack it, so I can just never queue that patch ;-) > @@ -2993,7 +2993,7 @@ config TEST_OBJPOOL > > If unsure, say N. > > -config INT_POW_TEST > +config INT_POW_KUNIT_TEST > tristate "Integer exponentiation (int_pow) test" if !KUNIT_ALL_TESTS > depends on KUNIT > default KUNIT_ALL_TESTS [1] https://lore.kernel.org/all/4092672cb64b86ec3f300b4cf0ea0c2db2b52e2e.1727699197.git.ge...@linux-m68k.org/ Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- ge...@linux-m68k.org In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds