On Tue, 30 Jun 2026 15:32:30 +0800 Hongfu Li <[email protected]> wrote:
> The main changes in this series are to refactor shared tracing and assertion
> helpers into a common file, unify both pkey selftests on pkey_assert() and
> per-test tracing for consistent diagnostics, and add missing mmap() return
> checks with MAP_FAILED used throughout for readability and consistency.
>
Thanks, I'll get this into mm.git for testing.
AI review read the pthread_create() manpage and didn't like
pkey_assert(). Please take a look?
https://sashiko.dev/#/patchset/[email protected]
> v8:
> - No code changes (relative to v7).
> - Updated Cc list: added developers identified via `git blame` and
> `git log` on tools/testing/selftests/mm/pkey*
Kevin, if you have the time, please.