Hi, > > The main changes in this series are to refactor shared tracing and assertion > > helpers into a common file, unify both pkey selftests on pkey_assert() and > > per-test tracing for consistent diagnostics, and add missing mmap() return > > checks with MAP_FAILED used throughout for readability and consistency. > > > > Thanks, I'll get this into mm.git for testing. > > AI review read the pthread_create() manpage and didn't like > pkey_assert(). Please take a look? > > > https://sashiko.dev/#/patchset/[email protected]
Thanks for your reply and the plan to queue this into mm.git for testing. I've gone through the Sashiko feedback regarding pkey_assert(). I agree this part needs adjustment, and I will fix this issue in the next revision of the patch series. Best regards, Hongfu

