> -----Original Message-----
> From: Breno Leitao <[email protected]>
> Sent: Wednesday, August 5, 2026 7:48 AM
> To: Haiyang Zhang <[email protected]>
> Cc: [email protected]; [email protected]; KY Srinivasan
> <[email protected]>; Haiyang Zhang <[email protected]>; Wei Liu
> <[email protected]>; Dexuan Cui <[email protected]>; Long Li
> <[email protected]>; Andrew Lunn <[email protected]>; David S.
> Miller <[email protected]>; Eric Dumazet <[email protected]>; Jakub
> Kicinski <[email protected]>; Paolo Abeni <[email protected]>; Konstantin
> Taranov <[email protected]>; Simon Horman <[email protected]>; Erni
> Sri Satya Vennela <[email protected]>; Dipayaan Roy
> <[email protected]>; Aditya Garg
> <[email protected]>; [email protected]; linux-
> [email protected]; Paul Rosswurm <[email protected]>
> Subject: [EXTERNAL] Re: [PATCH net-next v2] net: mana: Extend RX CQE
> coalescing up to 8 packets
> 
> On Fri, Jul 31, 2026 at 02:22:53PM -0700, Haiyang Zhang wrote:
> > From: Haiyang Zhang <[email protected]>
> >
> > To support up to 8 packets per CQE, update related CQE processing
> > code and structures.
> > Update ethtool handlers to set this feature.
> > Update per queue stat to show the coalesced CQE counters.
> > This feature is supported on NIC hardware showing the relevant
> > PF flag.
> >
> > Signed-off-by: Haiyang Zhang <[email protected]>
> 
> Reviewed-by: Breno Leitao <[email protected]>
> 
> 
> > +/* 8-pkt mode packs up to 2 packets per PPI entry */
> > +#define MANA_CQE_COAL_PKTS_8 8
> 
> nit: The name encodes the value, so a future 16-packet mode would need
> a second macro with the same role.  Wouldn't something like
> MANA_RXCOMP_MAX_COAL_PKTS age better?

The FW API uses mana_cqe_type like CQE_RX_COALESCED_8 for the CQE coalescing
x8, so I followed the same convention for the naming here.
When it supports 16pkt mode, we will decide if we rename this one or add a
new name based on the future API.

Thanks,
- Haiyang


Reply via email to