On Sat, Aug 15, 2026 at 05:04:32PM +0100, Bradley Morgan wrote:
> >Rename function to prov_vec (from do_proc_vec).
> 
> s/prov_vec/proc_vec/, the diff renames it to proc_vec.
> 
> Also the SIZE_MAX comment in proc_vec() only talks about the no
> parsed element case, but after 3/4 a kmemdup failure leaves
> left_nbyte unset too (it goes to out before buf_left_final gets
> written). So the sentinel covers -ENOMEM as well, a line saying so
> would help.
> 
> The split itself is fine, so with the typo fixed:

This comment is more about why it is OK to use SIZE_MAX. The case where
kmemdup fails falls into the "no elements parsed".

Thx for the review.

> 
> Reviewed-by: Bradley Morgan <[email protected]>
> Thanks!

Attachment: signature.asc
Description: PGP signature

Reply via email to