On Friday, January 04, 2013 05:36:55 PM Bjorn Helgaas wrote: > On Fri, Jan 4, 2013 at 5:19 PM, Yinghai Lu <ying...@kernel.org> wrote: > > On Fri, Jan 4, 2013 at 4:14 PM, Rafael J. Wysocki <r...@sisk.pl> wrote: > >> On Friday, January 04, 2013 04:03:01 PM Yinghai Lu wrote: > >>> On Fri, Jan 4, 2013 at 3:38 AM, Rafael J. Wysocki <r...@sisk.pl> wrote: > >>> >> --- a/arch/x86/include/asm/pci.h > >>> >> +++ b/arch/x86/include/asm/pci.h > >>> >> @@ -14,6 +14,7 @@ > >>> >> struct pci_sysdata { > >>> >> int domain; /* PCI domain */ > >>> >> int node; /* NUMA node */ > >>> >> + void *acpi_handle; > >>> >> #ifdef CONFIG_X86_64 > >>> >> void *iommu; /* IOMMU private data */ > >>> >> #endif > >>> >> > >>> > >>> acpi_handle is not good name and it is confusing. > >> > >> Well, what would be a better name in your opinion? > >> > >> I was going to put that into a #ifdef CONFIG_ACPI / #endif, so what about > >> calling it acpi_data? > > > > yes, with #ifdef, you can use acpi_handle type directly. > > > > it is acpi handle for pci_root. > > > > so would call int pci_root_acpi_handle ? > > I just copied the name from the corresponding ia64 code. I don't care > if you want to change it, but I think there is *some* value in keeping > the x86 and ia64 code as similar as possible because it would be nice > to converge it some day.
Well, the corresponding data structure for ia64 is called struct pci_controller, so it is quite obvious what acpi_handle in there means. :-) Since the data structure for x86 is called struct pci_sysdata and the data type for the field in question may be acpi_handle, perhaps we can call that field simply "root_handle"? Alternatively, in analogy with the iommu we could use void * as its data type and call it simply "acpi". That said I'm fine with using just "void *acpi_handle" as you did, but I would do the #ifdef CONFIG_ACPI / #endif around it anyway. I wonder what Peter thinks? Thanks, Rafael -- I speak only for myself. Rafael J. Wysocki, Intel Open Source Technology Center. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/