On Mon, Jan 07, 2013 at 02:19:15PM -0800, Paul E. McKenney wrote:
> On Mon, Jan 07, 2013 at 09:56:06AM -0800, Josh Triplett wrote:
> > On Mon, Jan 07, 2013 at 08:57:48AM -0800, Paul E. McKenney wrote:
> > > On Mon, Jan 07, 2013 at 07:58:10AM -0800, Josh Triplett wrote:
> > > > This patch seems reasonable to me, but the repeated use of #if
> > > > defined(CONFIG_SMP) || defined(CONFIG_RCU_TRACE) seems somewhat
> > > > annoying, and fragile if you ever decide to change the conditions.  How
> > > > about defining an appropriate symbol in Kconfig for stall warnings, and
> > > > using that?
> > > 
> > > But I only just removed the config option for SMP RCU stall warnings.  ;-)
> > > 
> > > But I must agree that "defined(CONFIG_SMP) || defined(CONFIG_RCU_TRACE)"
> > > is a bit obscure.  The rationale is that RCU stall warnings are
> > > unconditionally enabled in SMP kernels, but don't want to be in
> > > TINY_RCU kernels due to size constraints.  I therefore put it under
> > > CONFIG_RCU_TRACE, which also contains other TINY_RCU debugging-style
> > > options.  Would adding a comment to this effect help?
> > 
> > I understand the rationale; I just think it would become clearer if you
> > added an internal-only Kconfig symbol selected in both cases and change
> > the conditionals to use that.
> 
> My concern was that this would confuse people into thinking that the
> code under those #ifdefs was all the stall-warning code that there was.
> 
> I suppose this could be forestalled with a suitably clever name...
> CONFIG_RCU_CPU_STALL_TINY_TOO?  Better names?

How about CONFIG_RCU_STALL_COMMON, with associated help text saying
"include the stall-detection code common to both rcutree and rcutiny"?

- Josh Triplett
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to