On 26/02/13 14:01, Laxman Dewangan wrote:
> On Tuesday 26 February 2013 06:46 PM, Ian Lartey wrote:
>> is_palmas_charger checks for the presence of charging
>> functionality in the device
>>
>> Signed-off-by: Graeme Gregory <g...@slimlogic.co.uk>
>> Signed-off-by: Ian Lartey <i...@slimlogic.co.uk>
>> ---
>>   include/linux/mfd/palmas.h |    5 +++++
>>   1 files changed, 5 insertions(+), 0 deletions(-)
>>
>> diff --git a/include/linux/mfd/palmas.h b/include/linux/mfd/palmas.h
>> index 3129f9a..98c0567 100644
>> --- a/include/linux/mfd/palmas.h
>> +++ b/include/linux/mfd/palmas.h
>> @@ -26,6 +26,11 @@
>>   /* The ID_REVISION NUMBERS */
>>   #define PALMAS_CHIP_OLD_ID        0x0000
>>   #define PALMAS_CHIP_ID            0xC035
>> +#define PALMAS_CHIP_CHARGER_ID        0xC036
>> +
>> +#define is_palmas(a)    (((a) == PALMAS_CHIP_OLD_ID) || \
>> +            ((a) == PALMAS_CHIP_ID))
>> +#define is_palmas_charger(a) ((a) == PALMAS_CHIP_CHARGER_ID)
>>   
>
> TI says this as TPS80036 and original palma as TPS65913/TPS65914. Not
> sure whether palma_charger is correct or not here.
>
> But above change looks good.
>
> Acked-by: Laxman Dewangan<ldewan...@nvidia.com>
I can confirm that the generic name of TPS80036 is palmas-charger as
decided at TI!

Graeme

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to