>   */
> -static inline void set_cold_file(struct f2fs_sb_info *sbi, struct inode
> *inode,
> +static inline void set_cold_files(struct f2fs_sb_info *sbi, struct inode
> *inode,
>               const unsigned char *name)
>  {
>       int i;
> @@ -108,7 +109,7 @@ static inline void set_cold_file(struct f2fs_sb_info
> *sbi, struct inode *inode,
>       int count = le32_to_cpu(sbi->raw_super->extension_count);
>       for (i = 0; i < count; i++) {
>               if (!is_multimedia_file(name, extlist[i])) {
> -                     F2FS_I(inode)->i_advise |= FADVISE_COLD_BIT;
> +                     set_cold_file(inode);
>                       break;
>               }
>       }
It is just my private opinion.
How about use this name "set_cold_file_from_list instead of set_cold_files ?

Thanks.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to