linux-kernel
Thread
Date
Earlier messages
Later messages
Messages by Thread
[PATCH v2 6/6] module: Limit ELF includes in linux/module.h to uapi/linux/elf.h
Petr Pavlu
Re: [PATCH v2] selftests/alsa: Test writes to IEC958 controls
HyeongJun An
Re: [PATCH v2] selftests/alsa: Test writes to IEC958 controls
Mark Brown
[PATCH 0/2] Minor bugfixes for kunit userns tests
Christian Brauner
[PATCH 2/2] userns: declare the KUnit-visible helpers whenever KUnit is enabled
Christian Brauner
Re: [PATCH 2/2] userns: declare the KUnit-visible helpers whenever KUnit is enabled
Jan Kara
Re: [PATCH 2/2] userns: declare the KUnit-visible helpers whenever KUnit is enabled
Bill Wendling
Re: [PATCH 0/2] Minor bugfixes for kunit userns tests
Bradley Morgan
[PATCH 1/2] userns: rename insert_extent() and sort_idmaps()
Christian Brauner
Re: [PATCH 1/2] userns: rename insert_extent() and sort_idmaps()
Jan Kara
Re: [PATCH 1/2] userns: rename insert_extent() and sort_idmaps()
Bill Wendling
[PATCH] kselftest: mm: remove exclusion of building soft-dirty test in arm64
Yeoreum Yun
Re: [PATCH] kselftest: mm: remove exclusion of building soft-dirty test in arm64
David Hildenbrand (Arm)
Re: [PATCH] kselftest: mm: remove exclusion of building soft-dirty test in arm64
Yeoreum Yun
Re: [PATCH] kselftest: mm: remove exclusion of building soft-dirty test in arm64
David Hildenbrand (Arm)
Re: [PATCH] kselftest: mm: remove exclusion of building soft-dirty test in arm64
Lorenzo Stoakes (ARM)
[PATCH] selftests/mm: skip khugepaged file tests if mkfs.xfs is unavailable
Jaeyeon Lee
Re: [PATCH] selftests/mm: skip khugepaged file tests if mkfs.xfs is unavailable
Lorenzo Stoakes (ARM)
Re: [PATCH] selftests/mm: skip khugepaged file tests if mkfs.xfs is unavailable
Andrew Morton
Re: [PATCH] selftests/mm: skip khugepaged file tests if mkfs.xfs is unavailable
Zi Yan
Re: [PATCH] selftests/mm: skip khugepaged file tests if mkfs.xfs is unavailable
Zi Yan
Re: [PATCH] selftests/mm: skip khugepaged file tests if mkfs.xfs is unavailable
Jaeyeon Lee
[PATCH v10 0/9] riscv: add SBI Supervisor Software Events support
Zhanpeng Zhang
[PATCH v10 3/9] riscv: sse: mask events during shutdown and kexec
Zhanpeng Zhang
[PATCH v10 4/9] drivers: firmware: add riscv SSE support
Zhanpeng Zhang
[PATCH v10 5/9] riscv: mm: avoid enabling interrupts for nofault page faults
Zhanpeng Zhang
[PATCH v10 6/9] perf: RISC-V: support callchains with SSE delivery
Zhanpeng Zhang
[PATCH v10 1/9] riscv: add SBI SSE extension definitions
Zhanpeng Zhang
[PATCH v10 8/9] selftests/riscv: add SSE test module
Zhanpeng Zhang
[PATCH v10 7/9] perf: RISC-V: add support for SSE event
Zhanpeng Zhang
Re: [PATCH v10 7/9] perf: RISC-V: add support for SSE event
Himanshu Chauhan
[PATCH v10 9/9] selftests/riscv: add perf user-stack SSE copy regression test
Zhanpeng Zhang
[PATCH v10 2/9] riscv: add support for SBI Supervisor Software Events extension
Zhanpeng Zhang
Re: [PATCH v2 0/3] virtio: synchronize callbacks during device reset
Michael S. Tsirkin
Re: [PATCH v3 3/9] KVM: guest_memfd: implement folio migration for non-confidential VMs
Garg, Shivank
Re: [PATCH v3 0/9] KVM: guest_memfd: folio migration for non-confidential VMs
Garg, Shivank
Re: [PATCH v2 1/8] md: pass a queue_limits down to ->hot_add_disk()
Nilay Shroff
[PATCH net-next v4 0/4] rtnetlink: dump link-layer multicast addresses
Yuyang Huang
[PATCH net-next v4 1/4] netlink: specs: rt-addr: fix the type of target-netnsid
Yuyang Huang
Re: [PATCH net-next v4 1/4] netlink: specs: rt-addr: fix the type of target-netnsid
Nicolas Dichtel
[PATCH net-next v4 2/4] rtnetlink: add AF_PACKET multicast dumps
Yuyang Huang
Re: [PATCH net-next v4 2/4] rtnetlink: add AF_PACKET multicast dumps
Nicolas Dichtel
[PATCH net-next v4 3/4] netlink: specs: rt-addr: document AF_PACKET multicast dumps
Yuyang Huang
Re: [PATCH net-next v4 3/4] netlink: specs: rt-addr: document AF_PACKET multicast dumps
Nicolas Dichtel
[PATCH net-next v4 4/4] selftests: net: test AF_PACKET multicast dumps
Yuyang Huang
Re: [PATCH net-next v4 0/4] rtnetlink: dump link-layer multicast addresses
Jakub Kicinski
Re: [PATCH net-next v4 0/4] rtnetlink: dump link-layer multicast addresses
Yuyang Huang
Re: [PATCH v3] PCI: hv: Warn when wait_for_response() waits indefinitely
Manivannan Sadhasivam
Re: [PATCH v3] PCI: hv: Warn when wait_for_response() waits indefinitely
Wei Liu
Re: [PATCH v3] PCI: hv: Warn when wait_for_response() waits indefinitely
Sahil Chandna
[PATCH] selftests: net: fou_mcast_encap: conditionally load fou module and skip IPv4 case
Qingshuang Fu
Re: [PATCH] selftests: net: fou_mcast_encap: conditionally load fou module and skip IPv4 case
Jakub Kicinski
Re: [PATCH] selftests: net: fou_mcast_encap: conditionally load fou module and skip IPv4 case
Qingshuang Fu
Re: [PATCH] selftests: net: fou_mcast_encap: conditionally load fou module and skip IPv4 case
Jakub Kicinski
Re: [PATCH] selftests: net: fou_mcast_encap: conditionally load fou module and skip IPv4 case
Qingshuang Fu
[PATCH] srcutree: Add lockdep and early-boot checks to synchronize_srcu_atomic()
Kunwu Chan
Re: [PATCH] srcutree: Add lockdep and early-boot checks to synchronize_srcu_atomic()
Paul E. McKenney
Re: [PATCH] srcutree: Add lockdep and early-boot checks to synchronize_srcu_atomic()
KunWu Chan
Re: [PATCH] srcutree: Add lockdep and early-boot checks to synchronize_srcu_atomic()
Paul E. McKenney
Re: [PATCH] srcutree: Add lockdep and early-boot checks to synchronize_srcu_atomic()
Zqiang
Re: [PATCH] srcutree: Add lockdep and early-boot checks to synchronize_srcu_atomic()
KunWu Chan
Re: [PATCH] srcutree: Add lockdep and early-boot checks to synchronize_srcu_atomic()
Paul E. McKenney
Re: [PATCH] srcutree: Add lockdep and early-boot checks to synchronize_srcu_atomic()
KunWu Chan
Re: [PATCH] srcutree: Add lockdep and early-boot checks to synchronize_srcu_atomic()
Zqiang
Re: [PATCH] srcutree: Add lockdep and early-boot checks to synchronize_srcu_atomic()
KunWu Chan
Re: [PATCH] srcutree: Add lockdep and early-boot checks to synchronize_srcu_atomic()
KunWu Chan
[PATCH v5 00/17] x86/msr: Inline rdmsr/wrmsr instructions
Juergen Gross
[PATCH v5 03/17] x86/msr: Minimize usage of native_*() msr access functions
Juergen Gross
[PATCH v5 08/17] x86/msr: Make wrmsrns() a first class citizen
Juergen Gross
[PATCH v5 04/17] x86/msr: Move MSR trace calls one function level up
Juergen Gross
[PATCH v5 16/17] x86/paravirt: Use alternatives for MSR access with paravirt
Juergen Gross
[PATCH v5 14/17] x86/paravirt: Switch MSR access pv_ops functions to instruction interfaces
Juergen Gross
[PATCH v5 05/17] x86/hyperv: Switch from __rdmsr() to native_rdmsrq()
Juergen Gross
[PATCH v5 12/17] x86/paravirt: Split off MSR related hooks into new header
Juergen Gross
[PATCH v5 13/17] x86/paravirt: Prepare support of MSR instruction interfaces
Juergen Gross
[PATCH v3 00/13] x86/msr: Drop 32-bit MSR interfaces
Juergen Gross
[PATCH v3 10/13] x86/msr: Remove wrmsr()
Juergen Gross
[PATCH v3 13/13] x86/msr: Simplify some rdmsrq() use cases
Juergen Gross
Re: [PATCH v3 13/13] x86/msr: Simplify some rdmsrq() use cases
Sean Christopherson
[PATCH v3 03/13] x86/msr: Remove rdmsr_safe()
Juergen Gross
Re: [PATCH v3 12/13] treewide: convert rdmsrq() from a macro to an inline function
Ilpo Järvinen
Re: [PATCH v3 12/13] treewide: convert rdmsrq() from a macro to an inline function
Jürgen Groß
Re: [PATCH v3 12/13] treewide: convert rdmsrq() from a macro to an inline function
Sean Christopherson
[PATCH v3 11/13] x86/msr: Remove rdmsr()
Juergen Gross
Re: [PATCH v3 12/13] treewide: convert rdmsrq() from a macro to an inline function
Reinette Chatre
[PATCH v6 0/2] dmaengine: atcdmac300: Add Andes ATCDMAC300 DMA driver
CL Wang
[PATCH v6 1/2] dt-bindings: dmaengine: Add support for ATCDMAC300 DMA engine
CL Wang
[PATCH v6 2/2] dmaengine: atcdmac300: Add driver for Andes ATCDMAC300 DMA controller
CL Wang
[PATCH v3] srcutree: Don't transition atomic SRCU to big in srcu_gp_end()
Kunwu Chan
Re: [PATCH v3] srcutree: Don't transition atomic SRCU to big in srcu_gp_end()
Paul E. McKenney
Re: [PATCH v3] srcutree: Don't transition atomic SRCU to big in srcu_gp_end()
KunWu Chan
Re: [PATCH v3] srcutree: Don't transition atomic SRCU to big in srcu_gp_end()
Bradley Morgan
Re: [PATCH v3] srcutree: Don't transition atomic SRCU to big in srcu_gp_end()
Paul E. McKenney
Re: [PATCH net-next v5 1/4] net: mana: track when the HWC has been handed to the PF
netdev-bot+sashiko
Re: [PATCH net-next v5 4/4] net: mana: add dynamic HWC queue depth with reinit path
netdev-bot+sashiko
Re: [PATCH net-next v5 2/4] net: mana: give each HWC message slot its own completion state
netdev-bot+sashiko
Re: [PATCH net-next v5 2/4] net: mana: give each HWC message slot its own completion state
Jakub Kicinski
[PATCH RFC] rpmsg: qcom_smd: reject interrupted channel waits
Slavin Liu
Re: [PATCH v1 0/3] lib/842: reject malformed streams before invalid memory accesses
Herbert Xu
[PATCH net-next] selftests: drv-net: add BIG TCP test cases
Narcisa Vasile
Re: [PATCH net-next] selftests: drv-net: add BIG TCP test cases
Jakub Kicinski
Re: [PATCH net-next] selftests: drv-net: add BIG TCP test cases
Narcisa Vasile
[PATCH 0/2] Add QMI TMD based cooling support for the Shikra CDSP and Modem
Dipa Ramesh Mantre
[PATCH 2/2] arm64: dts: qcom: shikra: Enable CDSP & Modem cooling
Dipa Ramesh Mantre
[PATCH 1/2] remoteproc: qcom_q6v5_pas: Add QMI TMD cooling support for Shikra
Dipa Ramesh Mantre
Re: [PATCH v9 6/6] selftests/mm: add a GUP selftest
Sarthak Sharma
Re: [PATCH v9 6/6] selftests/mm: add a GUP selftest
David Hildenbrand (Arm)
Re: [PATCH v4 04/19] crypto: cmh - add SHA-2/SHA-3/SHAKE ahash
Herbert Xu
RE: [PATCH v4 04/19] crypto: cmh - add SHA-2/SHA-3/SHAKE ahash
Ousherovitch, Alex
Re: [PATCH] x86/init: Initialize wall clock in get_rtc_noop()
Hardik Garg
Re: [PATCH] x86/init: Initialize wall clock in get_rtc_noop()
Roman Kisel
Re: [PATCH] x86/init: Initialize wall clock in get_rtc_noop()
Naman Jain
Re: [PATCH] x86/init: Initialize wall clock in get_rtc_noop()
vdso
Re: [PATCH net-next v2] selftests: net: move log_test to lib file and remove duplicate code
Hangbin Liu
Re: [PATCH net-next v2] selftests: net: move log_test to lib file and remove duplicate code
Jakub Kicinski
[PATCH] selftests: netfilter: fix nft_audit.sh auditd detection
Jin Li
[PATCH v2] srcutree: Skip torture to-big transition for atomic SRCU
Kunwu Chan
Re: [PATCH v2] srcutree: Skip torture to-big transition for atomic SRCU
Paul E. McKenney
[PATCH] remoteproc: sysfs: Fix stale coredump attribute documentation
Yonghao Zhang
Re: [PATCH] remoteproc: sysfs: Fix stale coredump attribute documentation
Mathieu Poirier
[PATCH v1] ALSA: virtio: reset device before deleting virtqueues
Yuho Choi
Re: [PATCH v1] ALSA: virtio: reset device before deleting virtqueues
Takashi Iwai
Re: [PATCH] arm64: dts: qcom: sm7225-fairphone-fp4: Disable PMK8350 PON
Bjorn Andersson
[PATCH bpf-next v10 0/2] bpf: BPF-driven proactive memcg reclaim
Hui Zhu
[PATCH bpf-next v10 1/2] mm/bpf: Add bpf_proactive_reclaim kfunc
Hui Zhu
Re: [PATCH bpf-next v10 1/2] mm/bpf: Add bpf_proactive_reclaim kfunc
bot+bpf-ci
Re: [PATCH bpf-next v10 1/2] mm/bpf: Add bpf_proactive_reclaim kfunc
Kumar Kartikeya Dwivedi
Re: [PATCH bpf-next v10 1/2] mm/bpf: Add bpf_proactive_reclaim kfunc
Shakeel Butt
[PATCH bpf-next v10 2/2] selftests/bpf: Add memcg async reclaim test
Hui Zhu
[PATCH] selftests/harness: Drain the test process group after a timeout
Alex Williamson
[PATCH v1] iommu/virtio: Reset device before deleting virtqueues on probe failure
Yuho Choi
Re: [PATCH net v4 3/7] net: stmmac: Rework S-VLAN handling
netdev-bot+sashiko
Re: [PATCH net v4 3/7] net: stmmac: Rework S-VLAN handling
Joseph Steel
RE: [PATCH net v4 3/7] net: stmmac: Rework S-VLAN handling
Ovidiu Panait
Re: [PATCH net v4 3/7] net: stmmac: Rework S-VLAN handling
Joseph Steel
Re: [PATCH net v4 4/7] net: stmmac: Do not advertise S-VLAN stripping when it is disabled
netdev-bot+sashiko
Re: [PATCH net] selftests/net: run tun tests in a dedicated network namespace
Jakub Kicinski
[PATCH v5 0/4] selftests: add shared Makefile for BPF selftests and a new memcg test
Ziyang Men
[PATCH v5 1/4] selftests: add shared lib.bpf.mk to build BPF progs and skeletons
Ziyang Men
[PATCH v5 4/4] selftests/sched_ext: build BPF schedulers via the shared lib.bpf.mk
Ziyang Men
Re: [PATCH v5 4/4] selftests/sched_ext: build BPF schedulers via the shared lib.bpf.mk
bot+bpf-ci
[PATCH v5 2/4] selftests/cgroup: add memcg_stat_cross_cpu correctness test for flush
Ziyang Men
Re: [PATCH v5 2/4] selftests/cgroup: add memcg_stat_cross_cpu correctness test for flush
bot+bpf-ci
[PATCH v5 3/4] selftests/hid: build the BPF program via the shared lib.bpf.mk
Ziyang Men
Re: [PATCH v5 3/4] selftests/hid: build the BPF program via the shared lib.bpf.mk
bot+bpf-ci
[PATCH net 0/2] net: psp: avoid conflicts with skb->decrypted and sk_validate_xmit_skb()
Daniel Zahka
[PATCH net 1/2] net: psp: avoid conflicts with skb->decrypted and sk_validate_xmit_skb()
Daniel Zahka
Re: [PATCH net 1/2] net: psp: avoid conflicts with skb->decrypted and sk_validate_xmit_skb()
netdev-bot+sashiko
Re: [PATCH net 1/2] net: psp: avoid conflicts with skb->decrypted and sk_validate_xmit_skb()
Daniel Zahka
Re: [PATCH net 1/2] net: psp: avoid conflicts with skb->decrypted and sk_validate_xmit_skb()
Daniel Zahka
[PATCH net 2/2] selftests: drv-net: psp: test PSP and TCP ULP mutual exclusion
Daniel Zahka
Re: [PATCH net 2/2] selftests: drv-net: psp: test PSP and TCP ULP mutual exclusion
Daniel Zahka
Re: [PATCH net 2/2] selftests: drv-net: psp: test PSP and TCP ULP mutual exclusion
Matthieu Baerts
[PATCH v8 1/2] fuse: don't BUG when the copy buffer is exhausted
Xiang Mei
[PATCH v8 2/2] fuse: return -E2BIG for an oversized SETXATTR over io-uring
Xiang Mei
Re: [PATCH net v4 7/7] selftests: drv-net: Add VLAN test
netdev-bot+sashiko
Re: [PATCH net v4 7/7] selftests: drv-net: Add VLAN test
Jakub Kicinski
Re: [PATCH net v4 5/7] net: stmmac: Disable S-Tag processing on dwmac4
netdev-bot+sashiko
Re: [PATCH net v4 2/7] net: stmmac: Stop toggling the EDVLP bit
netdev-bot+sashiko
Re: [PATCH net v4 1/7] net: stmmac: Remove VLAN perfect matching dead code
netdev-bot+sashiko
Re: [PATCH net v4 6/7] selftests: drv-net: Move _set_ethtool_feat() into lib
Jakub Kicinski
Re: [PATCH net-next V4 11/14] net/mlx5e: psp: Dynamically reconfigure based on SHAMPO mode
netdev-bot+sashiko
Re: [PATCH net-next V4 10/14] net/mlx5e: shampo: Flush session on PSP mismatch
netdev-bot+sashiko
Re: [PATCH net-next V4 14/14] selftests: drv-net: Add PSP HW GRO conformance tests
netdev-bot+sashiko
Re: [PATCH net-next V4 14/14] selftests: drv-net: Add PSP HW GRO conformance tests
Jakub Kicinski
Re: [PATCH net-next V4 14/14] selftests: drv-net: Add PSP HW GRO conformance tests
Cosmin Ratiu
Re: [PATCH net-next V4 14/14] selftests: drv-net: Add PSP HW GRO conformance tests
Cosmin Ratiu
Re: [PATCH net-next V4 09/14] net/mlx5e: psp: Add an rx_decap steering table
netdev-bot+sashiko
Re: [PATCH net-next V4 01/14] net/mlx5e: Generalize TC <-> IPsec mutual exclusion
netdev-bot+sashiko
Re: [PATCH net-next V4 01/14] net/mlx5e: Generalize TC <-> IPsec mutual exclusion
Jakub Kicinski
Re: [PATCH net-next V4 13/14] selftests: net: gro: Add PSP encapsulation and encryption
netdev-bot+sashiko
Re: [PATCH net-next V4 04/14] net/mlx5e: macsec: Block TC offload when MACsec is enabled
netdev-bot+sashiko
Re: [PATCH v2] objtool/klp: Fix checksums for constant pool references
Joe Lawrence
Re: [PATCH v5 00/16] Add dmabuf read/write via io_uring
Jens Axboe
Re: [PATCH v5 00/16] Add dmabuf read/write via io_uring
Jens Axboe
Re: [PATCH v5 00/16] Add dmabuf read/write via io_uring
Pavel Begunkov
Re: [PATCH net] vsock: Do not reset a TCP_CLOSING socket
Michal Luczaj
[PATCH] 6lowpan: do not compress headers that are not fully present
Farhad Alemi
Re: [PATCH] 6lowpan: do not compress headers that are not fully present
Eric Dumazet
Re: [PATCH] clk: qcom: ipq-cmn-pll: Assign .num before accessing .hws
Bjorn Andersson
Re: [PATCH] KEYS: trusted: Fix tpm2_load_cmd() boundary check
Stefano Garzarella
Re: [PATCH] KEYS: trusted: Fix tpm2_load_cmd() boundary check
Jarkko Sakkinen
Re: [PATCH net-next v3 03/10] net: broadcom: fix typos in comments
Simon Horman
Re: [PATCH 2/2] lib/tests: Add KUnit test for struct stack_trace __counted_by_ptr attribute
Bill Wendling
Re: [PATCH 2/2] lib/tests: Add KUnit test for struct stack_trace __counted_by_ptr attribute
Bill Wendling
Re: [PATCH 2/2] lsm: fix size queries for getselfattr with NULL buffer
Paul Moore
[PATCH 0/2] arm64: gcs: Return -EPERM when changes are prevented by locking
Mark Brown
[PATCH 1/2] arm64: gcs: Return -EPERM not -EBUSY for prctl() locking failures
Mark Brown
[PATCH 2/2] kselftest/arm64: Check for -EPERM not -EBUSY in the locking test
Mark Brown
Re: [PATCH 8/8] KVM: selftests: Add nested pre-fault test for arm64
Fuad Tabba
Re: [PATCH 8/8] KVM: selftests: Add nested pre-fault test for arm64
Lorenzo Stoakes (ARM)
Re: [PATCH 8/8] KVM: selftests: Add nested pre-fault test for arm64
Itaru Kitayama
Re: [PATCH 8/8] KVM: selftests: Add nested pre-fault test for arm64
Lorenzo Stoakes (ARM)
Re: [PATCH 8/8] KVM: selftests: Add nested pre-fault test for arm64
Wei-Lin Chang
Re: [PATCH 8/8] KVM: selftests: Add nested pre-fault test for arm64
Lorenzo Stoakes (ARM)
Re: [PATCH 6/8] KVM: selftests: Enable pre_fault_memory_test for arm64
Fuad Tabba
Re: [PATCH 6/8] KVM: selftests: Enable pre_fault_memory_test for arm64
Lorenzo Stoakes (ARM)
Re: [PATCH 0/8] KVM: arm64: Add KVM_PRE_FAULT_MEMORY support
Fuad Tabba
Re: [PATCH 0/8] KVM: arm64: Add KVM_PRE_FAULT_MEMORY support
Lorenzo Stoakes (ARM)
RE: [PATCH v2 3/3] x86/irq, iommu/amd, PCI: Drop redundant irq_retrigger inits
Michael Kelley
Earlier messages
Later messages