Saves repeating "(void __force *)__uptr" but it's less clear.  Using
the output of PTR_RET() to determine the error rather than just
testing IS_ERR() is odd.

For example, I *assume* __gptr_to_uptr() never returns NULL?  Because
the __ret would be 0 for the old code.  The new version is clearer, IMHO:
it would try to get_user() on that address.

If you hate this variant, I can just s/PTR_RET/PTR_ERR_OR_ZERO/ instead.

Cc: Heiko Carstens <heiko.carst...@de.ibm.com>
Cc: Christian Borntraeger <borntrae...@de.ibm.com>
Cc: Martin Schwidefsky <schwidef...@de.ibm.com>
Signed-off-by: Rusty Russell <ru...@rustcorp.com.au>
---
 arch/s390/kvm/gaccess.h | 12 ++++++++----
 1 file changed, 8 insertions(+), 4 deletions(-)

diff --git a/arch/s390/kvm/gaccess.h b/arch/s390/kvm/gaccess.h
index 302e0e5..99d789e 100644
--- a/arch/s390/kvm/gaccess.h
+++ b/arch/s390/kvm/gaccess.h
@@ -42,9 +42,11 @@ static inline void __user *__gptr_to_uptr(struct kvm_vcpu 
*vcpu,
 ({                                                             \
        __typeof__(gptr) __uptr = __gptr_to_uptr(vcpu, gptr, 1);\
        int __mask = sizeof(__typeof__(*(gptr))) - 1;           \
-       int __ret = PTR_RET((void __force *)__uptr);            \
+       int __ret;                                              \
                                                                \
-       if (!__ret) {                                           \
+       if (IS_ERR((void __force *)__uptr)) {                   \
+               __ret = PTR_ERR((void __force *)__uptr);        \
+       } else {                                                \
                BUG_ON((unsigned long)__uptr & __mask);         \
                __ret = get_user(x, __uptr);                    \
        }                                                       \
@@ -55,9 +57,11 @@ static inline void __user *__gptr_to_uptr(struct kvm_vcpu 
*vcpu,
 ({                                                             \
        __typeof__(gptr) __uptr = __gptr_to_uptr(vcpu, gptr, 1);\
        int __mask = sizeof(__typeof__(*(gptr))) - 1;           \
-       int __ret = PTR_RET((void __force *)__uptr);            \
+       int __ret;                                              \
                                                                \
-       if (!__ret) {                                           \
+       if (IS_ERR((void __force *)__uptr)) {                   \
+               __ret = PTR_ERR((void __force *)__uptr);        \
+       } else {                                                \
                BUG_ON((unsigned long)__uptr & __mask);         \
                __ret = put_user(x, __uptr);                    \
        }                                                       \
-- 
1.8.1.2

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to